2

tldr; VCSA won't load upon external NAT port forward connection.

I am trying to login to the vSphere Web Client (VCSA web client) from an external IP address. I have a functioning NAT port forward from the URL to the VCSA web client. I am able to connect to the URL and it redirects me to the internal IP address. Once I click on the "vSphere Client (HTML5) - partial functionality" or the flash version, neither one loads and times out.

I have allowed numerous ports including 80, 443, 2012, 9443, 7444, 902, and many more according to the VCSA documentation through pfSense, but the web client still refuses to load. Various browsers and machines externally have been used. I can access VCSA web client internally. I have tried searching all over Google to no avail.

Originally, I was using an ESXi portal to manage my virtual machines, but got another server. I clustered the 2 servers together using VCSA and now want to manage them from the VCSA web client together rather than a single host at a time with the ESXi portal. The URL originally redirected successfully the user to the ESXi portal, but simply changing the IP address in pfSense to the VCSA server did not work.

I believe the problem is a pfSense firewall issue not allowing outbound communication from the VCSA web client to my external machine. Another issue I have is when I attempt to ping the URL or the IP address, I do not get a response despite allowing ICMP requests in and out. Nor can I connect to the URL by typing in the IP address.

vSphere Version: 6.5. URL: fake.website.com. External IP address: 1.2.3.4. Internal NAT VCSA IP address: 192.168.1.19.

  • What error you have? When I try to do the same with ESXi 5.5, it's just redirect me to wrong IP address. – Alexander Tolkachev Jan 14 '18 at 20:56
  • There is no error code. It's simply the VCSA web client will not load and will timeout which I think is a firewall issue. – Zamanry Jan 15 '18 at 7:29
  • How do you access the vCenter from the external IP address? https://fake.website.com, https://1.2.3.4 or https://192.168.1.19? What's the URL that times out? – Mario Lenz Jan 15 '18 at 20:04
  • I can access it via https://fake.website.com, and not via the external/internal IP addresses or even when I include a port number. I should not be able to access it by the internal IP. I think it is a DNS issue. – Zamanry Jan 15 '18 at 20:18
  • Please don't use words like 'SOLVED" in question titles. This doesn't mark a question as solved. If the question truly is solved, please post an answer and then mark the answer. – Michael Hampton Feb 6 '18 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.