0

I am getting this error when trying to run Resume-VMReplication VMName.

"Resume-VMReplication : Hyper-V encountered an error trying to access an object on computer 'GBYOR-SHP object was not found. The object might have been deleted, or you might not have permission to perform that the Virtual Machine Management service on the computer is running. If the service is running, tr task again by using Run as Administrator. At line:1 char:1 + Resume-VMReplication GBYOR-VSDC1 + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (:) [Resume-VMReplication], VirtualizationException + FullyQualifiedErrorId : ObjectNotFound,Microsoft.HyperV.PowerShell.Commands.ResumeVMReplication"

I have tried to suspend replication by running Suspend-VMReplication VMName, and that works as expected. I can manually resume the replication via the GUI. However the goal is to schedule, and for that I'll need to run the Powershell command.

I have tried to run Resume-VMReplication on different VMs but get exactly the same issue.

I have added my user account to the Hyper-V Administrators group on the host, logged off and logged back on to the Hyper-V host.

We're running Hyper-V on Windows Server 2016 Datacenter.

0

You can try this:

Get-VM -Name "XXX" | Resume-VMReplication

Because with the first Get-VM cmdlet obtain the VM object (not only the name) and pass it with the pipeline.

Share with us the result!

| improve this answer | |
  • Hi Victor Unfortunately I get the exact same error. I tried running Get-VM -Name "NameOfServer" | Suspend-VMReplication on another VM and it suspends the replication. However running the above but swapping Suspend for Resume results in the original error on the other VM. – Jamie Sandell Jan 16 '18 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.