0

I have a developer who is able to connect to Oracle database using SQL*Plus from command line.

But the person is not able to connect by using SQL*Developer.

The error is as follows :

"IO Error: The network adapter could not establish the connection"

  • 1
    That means you use the wrong host / port / whatever in SQL Developer. Using tnsnames? Or simple connection? – Lenniey Jan 15 '18 at 16:46
  • I am using simple connection. – oradbanj Jan 15 '18 at 16:49
  • Compare the SQL connection string to the one entered in SQL Developer, or edit them into your question. – Lenniey Jan 15 '18 at 16:52
  • On Command prompt, I am using SQLPLUS U/P@server, where server name is IP address. In SQL*Develoer, I am using Basic connection, and I am specifying relevant entries in Username, Password, Hostname (IP address), Port and Service_Name – oradbanj Jan 15 '18 at 17:15
  • This seems to be something specific to SQL*Developer. I tried using a different client tool and am able to connect. – oradbanj Jan 15 '18 at 17:21
1

Here are some of the things I did to resolve the problem.

  1. Download latest version of SQL*Developer ( I downloaded 17.4.0 )
  2. Go to Tools -> Preferences -> Database -> Advanced
  3. At the bottom of the screen look for "Oracle Client" and "Use OCI/Thick driver"
  4. Press "Configure" and set Oracle client to ORACLE_HOME
  5. Press "Browse" and set TNSNAMES.ORA directory

That resolved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.