I can't get rsync to work between 2 FreeBSD server. It always hangs during transfer or dry-run.

Setup:

rsync version 3.1.2 protocol version 31

1 FreeBSD 10.3-RELEASE-p24 server which mounts a windows server 2012 share like so:

//user@Server/Folder  /mnt/folder  smbfs rw,-N,-I[windowServerIp],-Wdomain,-Eutf8:cp850 0 0

1 FreeBSD 11.1-RELEASE-p4 server with ZFS all around.

Observed facts:

  • If I use rsync to send files from the windows share to zfs over ssh, it works fine.
  • If I use rsync to copy the same problematic folder from zfs to zfs, it works fine.
  • No error is logged, even with the most verbose options (ssh and rsync).
  • It always hangs on different files, small or large. Sometimes it succeeds in transfering some files, but it always ends up stuck with a high cpu usage and nothing else happens (yes, I left it run for a very long time to see if it would complete).
  • When it hangs, only the receiving windows share server rsync process has a high cpu, the rsync process on the zfs server goes to 0%.
  • Transferring the folder over scp in the same directories, using the same user that runs rsync works fine
  • Dry runs of rsync end up stuck also, not only the real transferts

Here is the latest (of sooooo many) rsync commands I tried:

rsync -avvvz --delete --ignore-errors --rsh='ssh -v -p12345' [zfsServerIP]:/folder/ /mnt/folder/

Somebody has experienced/resolved something like this? If not, are there some alternatives to rsync on FreeBSD?

EDIT: I thought I fixed it with the param "--iconv=." but it doesn't work. It completes fine but it just skips the file giving the message "cannot convert filename".

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.