I am unable to get vmware workstation to work in Ubuntu 9.10. The same installer worked fine in 9.04. Installation is successful, but initialization is not. Does anybody know a fix?

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 9.10
Release:        9.10
Codename:       karmic


I don't think my key will work for version 7, sadly. I have a free 365 day student evaluation license.

  • Use VirtualBox: it's not worse from any point of view, and is FREE :) I also had problems when tried to install VMWare (used it while 'I WAS a PC'): it launched okay, but keyboard was not functioning at all :)
    – kolypto
    Dec 1, 2009 at 3:08
  • VirtualBox doesn't support paravirtualisation by the way
    – Chopper3
    Jan 1, 2010 at 15:08

3 Answers 3


I run VMWare Workstation on Ubuntu 9.10 Karmic. In order to get it to install I had to follow these directions which basically state:

[...] By default the installer would freeze at the “Configuring…” stage, never actually completing.

1) The first step consists in installing the program via terminal and suppressing the warnings otherwise eventually stucking the installer. [...]

chmod u+x VMware-Workstation-6.5.3-185404.i386.bundle
while true; do sudo killall -9
vmware-modconfig-console; sleep 1;

done in a separate terminal run:

sudo ./VMware-Workstation-6.5.3-185404.i386.bundle --ignore-errors

when the installer has finished, terminate the previous command (while true…) with a CTRL+C or simply close the terminal window.

vmware-modconfig --console --install-all

[...] The mouse automatically ungrabs outside an area of 640 x 480 (vga resolution) edit file /etc/vmware/bootstrap add at the bottom


WS 6.5.1 was released in November of 2008, before Ubuntu 9.10 was released so it definitely won't be supported. You should try upgrading to Workstation 6.5.4, which should be a free upgrade. According to this, WS 6.5.4 doesn't officially support Ubuntu 9.10 guests, but it is more likely to work than 6.5.1.


Which version of VMWare Workstation?

I have:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 9.10
Release:    9.10
Codename:   karmic

$uname -r

with VMWare (md5sum):

a4286d08c2b302f1d3a164dcdc36c884  VMware-Workstation-Full-7.0.0-203739.i386.bundle

working OK. I had problems with the last version of 6.5 on the 9.4 ubuntu.

  • I added some more info above.
    – kzh
    Dec 1, 2009 at 0:28
  • What is your "uname -r" output?
    – gm3dmo
    Dec 1, 2009 at 15:22
  • $ uname -r 2.6.31-15-generic
    – kzh
    Dec 2, 2009 at 2:52
  • Sorry, I should have asked about uname -a: $ uname -a Linux rover 2.6.31-15-generic-pae #50-Ubuntu SMP Tue Nov 10 16:12:10 UTC 2009 i686 GNU/Linux
    – gm3dmo
    Dec 2, 2009 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.