0

Good afternoon,

I am new on linux distribution and I have a problem I did not manage to fix. I am sorry if the problem is easy to fix... I tried to update my debian computer with apt-get update... But at the end, I obtained the following thing :

.W: Erreur de GPG : http://repo.mongodb.org jessie/mongodb-org/3.4 Release : Les signatures suivantes ne sont pas valables : KEYEXPIRED 1515625755

I don't know how to fix it... The computer date is correct (it is jeudi 18 janvier).. I checked some forums but it did not really help me...

Thank you in advance !

2

This works for me with mongo 3.4

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6 && sudo apt-get update

0

To fix this, you need to "install" the key again

sudo apt-key adv --keyserver <mongodb repo keyserver> --recv-keys <last 8 digits of key>

Some googling resulted in this

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv EA312927

taken from here

  • Thank you for your rapid response. I wrote : apt-key adv --keyserver <mongodb repo keyserver> --recv-keys A15703C6 I tried it and I get the following things : bash: mongodb: Aucun fichier ou dossier de ce type ... – balou Jan 18 '18 at 14:56
  • I found this on an external site. This works for me, I'll update my answer. – Robert Riedl Jan 18 '18 at 15:00
  • When I wrote : apt-key list | grep "expirée", I obtained : pub 4096R/F6D61D45 2015-05-27 [expirée : 2017-05-26] So I tried the 2 above commands with the key digits "F6D61D45"... Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.G3nMFB1M1e --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/chris-lea-redis-server.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/d [...] Is is normal ? – balou Jan 18 '18 at 15:40
  • Did you try apt-get update after that ? – Robert Riedl Jan 18 '18 at 15:44
  • I did and the "W: Erreur de GPG : repo.mongodb.org jessie ..." dit not appear anymore ! However, when I checked the validity of the keys (apt-key list | grep "expirée"), I obtained : pub 4096R/F6D61D45 2015-05-27 [expirée : 2017-05-26] So the key is still expired right ? – balou Jan 18 '18 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.