1

For a specific Azure tenant, when I create a new app registration, it just disappears and is nowhere to be found.

It gets assigned an application id:

enter image description here

I am also able to create a key for it:

enter image description here

and view properties for it:

enter image description here

But when I go to refresh the list of apps (or go somewhere else to pick it for identity access control) - it is just nowhere to be found. Like this:

enter image description here

If I go to Azure Active Directory Overview, it says I have 4 applications (which fits the number of times I have create a new app registration) - but if I click it - nothing found.

enter image description here

Note:

  • The account I am using a global admin
  • This works in all other tenants
  • I have also tried doing this using the account that owns the tenant, same issue
  • I have tried logging out and back in
  • I have waited (days), does not change anything

What is happening?

2

This is because that you filtered My apps in App registrations.

Solution:

Choose All apps in the columms like this:

enter image description here

enter image description here

Addtional:

If you want the app to shows in My apps, you need to set the owner of this app.

Go to Azure Portal > Azure Acitve Directory > Application registrations > Your App > Settings > Onwers > Add owner > Add your Account > Select

Please let me know if it helps!

  • ...Facepalm... I don't know how I missed that. Thank you very much. :) – Kjensen Jan 22 '18 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.