0

I sending my Asterisk's logs to Graylog. (its working fine) But the rSyslog write every asterisk's log to /var/log/messages not to the /var/log/asterisk/full.

Asterisk logger.conf:

[general]
;rotatestrategy=timestamp
[logfiles]
console => notice,error,warning
messages => notice,warning,error
full => notice,warning,error,debug,verbose,dtmf,fax
warning => warning
error => error

syslog.local0 => warning,error

rSyslog.conf:

# Log anything (except mail) of level info or higher.
# Don't log private authentication messages!
*.info;mail.none;authpriv.none;cron.none;local0.none     /var/log/messages

# The authpriv file has restricted access.
authpriv.*                                              /var/log/secure

# Log all the mail messages in one place.
mail.*                                                  -/var/log/maillog


# Log cron stuff
cron.*                                                  /var/log/cron

# Everybody gets emergency messages
*.emerg                                                 :omusrmsg:*

# Save news errors of level crit and higher in a special file.
uucp,news.crit                                          /var/log/spooler

# Save boot messages also to boot.log
local7.*                                                /var/log/boot.log

local0.*                                                /var/log/asterisk/full

# ### begin forwarding rule ###
# The statement between the begin ... end define a SINGLE forwarding
# rule. They belong together, do NOT split them. If you create multiple
# forwarding rules, duplicate the whole block!
# Remote Logging (we use TCP for reliable delivery)
#
# An on-disk queue is created for this action. If the remote host is
# down, messages are spooled to disk and sent when it is up again.
#$ActionQueueFileName fwdRule1 # unique name prefix for spool files
#$ActionQueueMaxDiskSpace 1g   # 1gb space limit (use as much as possible)
#$ActionQueueSaveOnShutdown on # save messages to disk on shutdown
#$ActionQueueType LinkedList   # run asynchronously
#$ActionResumeRetryCount -1    # infinite retries if host is down
# remote host is: name/ip:port, e.g. 192.168.0.1:514, port optional
#*.* @@remote-host:514
local0.* @172.16.10.234:9901
# ### end of the forwarding rule ###

How can I disable this? A tried to add local0.none to /var/log/messages line but it doesnt work.

(English is not my mother tongue; please excuse any errors on my part. And thank you for help.)

0

First, did you restart the rsyslog daemon after you changed the rsyslog.conf file?

sudo service rsyslog restart

  • Yea, I restarted the rSyslog. – G3ph4z Jan 23 '18 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.