I set up a django-cms installation version 3.4.4 with nginx and gunicorn. Then I removed the installation and installed the new 3.4.5 version.

Pip confirms this worked:

(myenv) user@s23:~/myenv$ pip3 list DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning. cmsplugin-filer (1.1.3) dj-database-url (0.4.2) Django (1.8.18) django-appconf (1.0.2) django-classy-tags (0.8.0) django-cms (3.4.5) (...)

When I run the server via manage.py, things work:

python3 manage.py runserver Performing system checks... System check identified no issues (0 silenced). January 23, 2018 - 14:28:33 Django version 1.8.18, using settings 'proj.settings' Starting development server at Quit the server with CONTROL-C. [23/Jan/2018 14:28:41] "GET /de/ HTTP/1.0" 200 13110 [23/Jan/2018 14:28:41] "GET /static/cms/css/3.4.5/cms.base.css HTTP/1.0" 304 0 [23/Jan/2018 14:28:41] "GET /static/cms/css/3.4.5/cms.welcome.css HTTP/1.0" 304 0 [23/Jan/2018 14:28:41] "GET /static/cms/js/dist/3.4.5/bundle.toolbar.min.js HTTP/1.0" 304 0

Starting the server with nginx works fine:

(myenv) user@s23:~/proj$ ~/init/proj start Starting svp .....................OK (myenv) user@s23:~/proj$ ~/init/nginx start Starting nginx: nginx. (myenv) user@s23:~/proj$ ps aux hf | grep user | grep gunicorn user 22837 0.0 0.0 34560 976 pts/1 S+ 14:55 0:00 | \_ grep gunicorn user 22410 0.0 0.0 89752 21572 ? S 14:54 0:00 /home/user/v/bin/python3 /home/user/v/bin/gunicorn -D -b unix:////home/user/proj/proj.sock --worker-class gevent --workers 1 --pid /home/user/proj/proj.pid proj.wsgi user 22415 1.4 0.0 174392 55916 ? S 14:54 0:00 \_ /home/user/v/bin/python3 /home/user/v/bin/gunicorn -D -b unix:////home/user/proj/proj.sock --worker-class gevent --workers 1 --pid /home/user/proj/proj.pid proj.wsgi

BUT, when I browse to the admin page or frontend, I'm informed that I'm still using version 3.4.4 and static files from this version are queried. This happens with other browsers as well, so it is not a client-side caching issue. So where are these html files be cached?


I executed runserver on the myenv environment, but had the variable DAEMON in ~/init/proj set to $HOME/v/bin/gunicorn which is a different virtualenv. On this virtualenv I still had the old django-cms version installed, thus the problem. Installing the new django version in the other virtualenv solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.