I've set up SSL for my domain and it works from Apache perspective.

The problem is that accessing my domain over HTTPS sometimes results in timeouts. When it doesn't work, it takes some time to access my website over HTTP but it never times out.

Why does this happen for HTTPS and is there a way to control timeout time for HTTPS?

My configuration: Apache 2.2.11 on CentOS 5

NameVirtualHost *:443
<VirtualHost *:443>
    SuexecUserGroup foo
    DocumentRoot /home/mydomain/www/
    ServerName example.com

    SSLEngine on
    SSLProtocol -all +TLSv1 +SSLv3
    SSLCertificateFile /path/example.com.com.crt
    SSLCertificateKeyFile /path/example.com.key
    SSLVerifyClient none
    SSLProxyVerify none
    SSLVerifyDepth 0
    SSLProxyVerifyDepth 0
    SSLProxyEngine off
    SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
    <Directory "/home/mydomain/www">
            AllowOverride all
            Options +FollowSymLinks +ExecCGI -Indexes
            AddHandler php5-fastcgi .php
            Action php5-fastcgi /cgi-bin/a.fcgi
            Order allow,deny
            Allow from all
    <Directory "/var/suexec/mydomain.com">
            AllowOverride None
            Options None
            Order allow,deny
            Allow from all


It's a self-signed certificate.
When visiting my domain works, it results in a SSL warning saying that the certificate is not trusted but accepting it lets me see the website over HTTPS.

2 Answers 2


I found the cause of this problem.

Port 443 was closed in my firewall configuration. It worked sometimes because my IP was added to firewall as a safe one. That's why it did not work for other IPs.

All I had to do is open port 443 in firewall and it works just fine :)

  • 3
    sudo ufw allow https Nov 28, 2015 at 7:24
  • 4
    OMG I just spent 2 hours trying to troubleshoot the same. facepalm
    – wogsland
    Feb 27, 2016 at 16:22
  • FUN fact - also works the other way around - here 80 was closed and timed out while 443 worked fine - and I thought my redirect was broken. Thanks anyway
    – Max
    Oct 26, 2022 at 13:13

Try checking the SSL installation at http://www.sslshopper.com/ssl-checker.html. It might be able to find a problem.

  • Test resulted in: mydomain.com resolves to Server Type: mydomain HTTP Server No SSL certificates were found on mydomain.com What I forgot to mention is that I have a self generated certificate.
    – 6bytes
    Nov 30, 2009 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .