6

What ports need to be open for IIS FTP servers on a Firewall and how to best do it and is it possible to configure the Firewall for IIS FTP that I have opened the right ports and it is good ?

Just opened port 21 but the server is not available, when opening all the ports the server is running.

p.s. As I understand from the wiki you need to open 21/TCP for commands, 20/TCP for data and 49152-65534/TCP dynamically.

update:

enter image description here

Russian version

1
  • Your question is confusing. First you wrote that you opened just port 21. Then you write that you understand that you need to open more ports. What did you try that? Jan 26 '18 at 18:56
3

I just created a 'New Rule' - opening TCP 20-21 and got it working. Microsoft default FTP Rules were still in place and activated, but were blocking the connection.

1
  • 2
    I had to do the same. The only difference is the allowed program (anything instead of svchost.exe, which I cannot change)
    – Matt
    Sep 30 '20 at 20:21
1

You just need to reset Windows 2016 server for preconfigures firewall rules in Windows Firewall start working. I had exactly same problem on few Windows server.

1

When you install IIS, it preconfigures firewall rules in Windows Firewall.

You may just need to enable those rules to make it working.

Go to Control Panel > System and Security > Windows Firewall > Advanced Settings > Inbound Rules and locate three "FTP server" rules. Make sure they are enabled. For details, see my article on Installing a secure FTP Server on Windows using IIS.


If this does not help, you need to give us more details. Particularly, what exact problem/error message are you getting. "Is not available" is pretty vague.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.