1

We have a hybrid Exchange environment with Exchange 2010 and a small number of mailboxes migrated to Exchange Online. We are using ADFS for authentication.

However, for mailboxes that have been migrated to Exchange Online, the Outlook 2013 autodiscover process fails.

Oddly, Outlook 2016 autodiscover works fine. Autodiscover also works fine for on-premise mailboxes. Users can authenticate to Outlook web fine via ADFS.

Outlook 2013 seems to have a problem at the point it is redirected to https://autodiscover-s.outlook.com/autodiscover/autodiscover.xml (normally the final step after first contacting on-premise CAS server). It then shows a logon prompt, however no credentials are accepted. If credentials are provided, they fail with 0x80004005. Screenshot below.

Troubleshooting attempted:

enter image description here

  • Might seem silly since 2016 is working but if you haven't yet run the Microsoft Remote Connectivity Analyzer against your autodiscover yet, I would try that, it might give you some clues. Also make sure the Outlook 2013 clients are fully up to date, and you might double check any GPOs that could be different between 2013 and 2016. – Todd Wilcox Jan 26 '18 at 17:40
  • Remote connectivity completes successfully, unfortunately. I have tried blocking GPO inheritance and got the same result. Opened a support ticket so will update when I have a resolution. – AdamR Jan 31 '18 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.