So I have the following setup:

  • Microsoft Windows 2012 R2 Virtual Private Server (from Microsoft Azure - Standard 1Bs 1 vcpu, 1 GB memory),
  • Metaquotes MetaTrader 4 Platform - which are running in VPS,
  • Expert Advisors in MQL4 Language - which are running in VPS,

So, I have my MT4 set up in my Virtual Private Server for latency reduction on my trades. However, my algorithms do not execute any trades whenever my VPS RDP is disconnected, despite that any programme that was running, should remain so unless I de-allocate the Virtual Machine via my Azure dashboard.

I only disconnect the RDP (this is purely clicking the "x" at the top of the screen), so my MT4 should (in theory) still run as normal (as is the point of a VPS in the first place).

I've looked at the journals on my MT4 platform and there are no errors relating to the failure to execute any trades, plus all the standard checks (allow automated trading, "Auto Trading" is turned on in MT4 Platform, allow "Live Trading" etc) are in accordance to the platforms requirements to execute automated trades.

My question is: it's obvious that disconnecting the RDP closes down the entire VPS system and therefore closes MT4 - preventing this from executing any trades. Is there a way in which I simply disconnect the RDP which results in my MT4 platform running as normal? Please feel free to ask for any clarification on anything mention in this post.


Disconnecting your RDP session will not be turning of the VM. However RDS will disconnect inactive sessions after a certain period of time. These settings are configured in your session collection settings:

enter image description here

  • How would I get onto RDS Collections? I search this in my VPS and nothing comes up? – Todd Gilbey Feb 5 '18 at 12:21
  • It sounds like your using RDS in remote admin mode, this UI if for full RDS mode. Remote admin mode is soley intended for undertaking remote administration tasks on the server, as you are running production applications you would be in breach of the licence using this mode, so you should switch to full RDS mode and purchase a Client Access Licence. Here is a good guide to doing a single server implementation of this -msfreaks.wordpress.com/2013/12/09/… – Sam Cogan Feb 13 '18 at 13:00
  • Awesome, I'll try this, & let you know how I get on. Pretty chaotic in the office here right now so I may be a while getting back to you. I've up'd your contribution as well. – Todd Gilbey Feb 14 '18 at 11:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.