2

I have to create a KMS infrastructure in my company: I've read loads of MS docs and how-tos, I've searched the net but I'm still unable to make it work as expected.

DNS is configured properly, returning the server name for SRV requests on _vlmcs._tcp.

First I tried to install a Win2016 server and maybe this should have been the best solution to license Win7, Win8, Win10 and Office 2016, but nowadays it's impossible to have a GUI; so I used server manager and connected to server (powersheel connection worked too), then installed "volume activation" role. But when I tried to configure it using Volume Activation Tools it failed to start, no way for me to make it work. So I gave up; I know I should have tried using powershell commands: anyone can eventually help me?

Anyway, being in the need of configuring it very quickly, I installed Win2012 Server R2, installed role, configured service applying the KMS key and activating it and everything started.

Then I turned a Win10 Pro on, used slmgr.vbs to remove the old MAK key, applied GVLK key for Win10 (W269N-WFGWX-YVC9B-4J6C9-T83GX), then run slmgr.vbs /ato to register license; but I keep getting error 0xC004F074. Running slmgr.vbs /dli on server I see requests are flowing and they fail every time.

  1. How can I understand what's wrong?
  2. Should I dismiss Win2012 Server R2 and force myself to use Win2016 Server to solve problems?
  3. Is VAMT (Volume Activation Management Tools) necessary or is it something useful?

UPDATE:
After installing Windows8.1-KB3058168-x64 and Windows8.1-KB3172614-x64 I've been able to update my KMS host key: now using slmgr /dli I see VOLUME_KMS_2012-R2_WIN10 channel.
Trying to license a Win10 Pro I still get the same error 0xC004F074, while on the server requests received and failed are increased by one.

UPDATE:
After installing Office 15, VOLUME_KMS and Office 16, VOLUME_KMS channels on KMS host and Office 2016 Pro downloaded from VLSC site, I tried to activate it using cscript ospp.vbs /act, unsuccessfully.
Server received activation request (counters increase) but on client I get this:

Installed product key detected - attempting to activate the following product:
SKU ID: removed
LICENSE NAME: Office 16, Office16ProPlusVL_KMS_Client edition
LICENSE DESCRIPTION: Office 16, VOLUME_KMSCLIENT channel
Last 5 characters of installed product key: WFG99
ERROR CODE: 0xC004F074
ERROR DESCRIPTION: The Software Licensing Service reported that the product could not be activated. No Key Management Service (KMS) could be contacted.

Please see the Application Event Log for additional information.
To view the activation event history run: cscript ospp.vbs /dhistorykms
NOTICE: A KB article has been detected for activation failure: 0xC004F074 FOR MORE INFORMATION PLEASE VISIT: http://support.microsoft.com/kb/2870357#Error0xC004F074

Again: my KMS host receives requests and counters increase, so I don't understand why the error states KMS host can't be found.
If I check events on client pc I find (for each registration attempt) an entry like this:

  • source: Security-SPP
  • event id: 12288
  • description: 0xC004F06C, 0x00000000, correct server FQDN:1688, 51250682-9583-4276-89f3-e843cabfb537, 2018/02/01 09:15, 1, 5, 0, 2de67392-b7a7-462a-b1ca-108dd189f588, 25
  • It does not start working until at least five failures. – Greg Askew Jan 31 '18 at 16:58
  • @GregAskew: I know the problem about activation limit, but I have 15 failures :( Should failures be from 5 different pcs? – Marco Jan 31 '18 at 17:42
1

Finally I've been able to solve the problem and wanted to post the answer just in case someone else faces the very same mess.

By looking at the event manager, I found a new error code and then I run slui.exe 0x2a 0x*error_code* to get the description: timestamp of the request was not valid.
I jumped on my seat because I read on Microsoft docs that server and client time must be not so different or requests could be discarded, but I was really sure time on both pc (server and client) was the same... so sure it was not true, sadly: server time was the same of client time (the ones showed on the tray bar), but date was different!! Server date was one day forward and I wasted half a day just for this little and stupid mistake.

After setting correct date on server, everything started working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.