Apache's default configuration includes something like this in ssl.conf:

SetEnvIf User-Agent ".*MSIE.*"
    nokeepalive ssl-unclean-shutdown
    downgrade-1.0 force-response-1.0

Do newer IE still require all of these workarounds?


The issue seemed to center mostly around uploading files to a host via an SSL secured session.

MS says it's been fixed as of IE7. Mentioned at the end of this article: http://blogs.technet.com/askperf/archive/2007/11/09/internet-explorer-and-ssl-closure-alerts.aspx

If it's still there in the latest version of Apache, I'd err on the side of caution and keep it in there. The performance hit for your server and IE clients is not as bad as rendering them unable to access parts of the site.

  • 1
    The blog is rather confused. Read the KB article it cites for the true story. It is actually a misfeature in Windows Server that trips another misfeature in IE6. – user207421 Jul 19 '12 at 13:01

That's Apache 2.2 or earlier. If you look at the configuration files supplied with Apache 2.4 you will see they have changed this to SetEnvIf User-Agent "MSIE [2-5]" etc. Clearly it isn't a problem with IE from version 6 onwards. I have recently been bitten by exactly this problem: this Apache default setting broke all MSIE clients of any description whatsoever: login times of over five minutes; some operations never completing at all.

I'm not sure who is to blame, although some credit must go to Microsoft for fixing it after a mere 5 buggy releases over a period of only about seven years.


Microsoft indicates that this is a hold-over from really old versions, and should be removed entirely. The comments in the blog post tend to back this up as well. http://blogs.msdn.com/b/ieinternals/archive/2011/03/26/https-and-connection-close-is-your-apache-modssl-server-configuration-set-to-slow.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.