0

I know this issue has been addressed a lot on the internet, but I never could find an answer that applies to my situation. I'm installing a Debian machine (9.3) using a PXE install, and a preseed file. When I'm configuring the preseed file to ignore missing firmware, the install continues fully unattended successfully.

I decided to change my initrd.gz file (on the PXE server) in such a way that it does contain the missing firmware files, so when the install detects the hardware and finds out that firmware is missing the firmware is installed.

This also works very well. The only problem is that one of the firmware files that is being installed is for a wireless adapter, which is being activated after the download of the firmware.

A little further on in the installation there is an attempt to get a DHCP address, and this is where it all goes wrong. For some reason the installation is trying to obtain an address over Wifi, which fails. From what I gather from the logs the installation procedure also tries to get an address from the other network card which is used to PXE boot from. This also fails (...) and a dialog appears asking me to choose the network adapter to use. That's not what I want obviously....

I've been searching for the last week, and all I could find is that it should be possible to add an extra parameter in the boot file, called BOOTIF=(mac_address_of_default_nic).

So, I tried to build the boot file (sorry for typo's, I'm doing this from somewhere else):

......
kernel debian-installer/amd64/linux
append auto=true priority=critical vga=788 initrd=debian-installer/amd64/initrd.gz preseed/url=tftp://192.168.0.30/preseed/debian-9-preseed.cfg BOOTIF=00:00:00:00:00:00
......

Of course, 00:00:00.... is something else. I tried using dashes instead of colons as well. No cure... Also read that you should use the extra parameter IPAPPEND 2 somewhere. Tried that as well, but that didn't help either.

I'm stuck and begin to wonder if it is at all possible...

1) Has anyone succeeded in forcing the installer to use a specific network adapter using this method ? 2) If I need to use the IPAPPEND parameter, does it make any difference where in the menu.cfg file I specify this ? (after the kernel... line, or after the append... line)

0

There is a kernel parameter to decide which network device should be used. Additionally the network parameters can be added, too.

In your case you should add "ip=eth0:dhcp" (change eth0 to the network interface you would like to use). See nfsroot.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.