3

I have configured DNS, NPT and active directory services on my server but I'm still struggling to connect FreeNAS to a domain. There is no firewall between these two. I've created a freenasAdmin user and added a new computer with all the necessary privileges. There is no adminui nor nis feature anymore in 2016 so I'm not quite sure I did it right. All the FreeNAS throws at me is can't connect o ldap connection timeout.

5
  • When a computer (=FN Device) is joining the domain, the computer account is created automatically; so just delete you existing machine account (or set is to 'trust'). If the FN Machine says 'no connection to LDAP' check this by yourself first.
    – bjoster
    Feb 7 '18 at 15:01
  • "There is no adminui nor nis feature anymore in 2016" WHAT?
    – JBaldridge
    Feb 7 '18 at 16:11
  • I apologize, I have not worked with *nix joined domain machines. I was not aware that there was a dedicated *nix gui surfaced at one point. However it looks like you can just move over to using Active Directory Administrative Center to edit the attributes the deprecated *nix gui edited.
    – JBaldridge
    Feb 8 '18 at 15:40
  • @JBaldridge you don't need to apologize....I don't know why bud I had to manually set the FQDN of DC and GC to use with FreeNAS.
    – Quest
    Feb 8 '18 at 21:03
2

I suppose you have a working Windows 2016 DC so I won't go into that.

In FreeNAS go to directory services -> active directory and click Advanced Mode.

  • Enter your domain name, Domain acc. and password (I used Administrator acc)
  • uncheck UNIX extensions
  • enter your site name (this can be found in server manager -> Tools -> Active Directory Sites and Services)
  • enter FQDN of your DC and GC
  • set Idmap backend to rip and SASL wrapping to sign
  • check enable
  • enter netBIOS name capitalized and hit save

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.