This is my working directory:

  • myproject.ini
  • myproject.py
  • myproject.sock
  • pycache
  • venv
  • wsgi.py


from flask import Flask
app = Flask(__name__)

def hello():
    return "<h1 style='color:blue'>Hello There!</h1>"

if __name__ == "__main__":


from myproject import app

if __name__ == "__main__":


module = wsgi:app

master = true
processes = 5

socket = myproject.sock
chmod-socket = 660
vacuum = true

die-on-term = true
#location of log files
logto = /var/log/uwsgi/%n.log

I also created a systemd Unit file


Description=uWSGI instance serve myproject

User = john
Group = www-data
ExecStart=/var/www/flaskapp/venv/bin/uwsgi --ini myproject.ini


and then

sudo systemctl start myproject
sudo systemctl enable myproject

Than configuration of nginx. nginx.conf I left unchanged but made corrections to /etc/nginx/sites-availible/myproject

server {
    listen 83;
    server_name my_external_ip;

    location / {
        include uwsgi_params;
        uwsgi_pass unix:/var/www/flaskapp/venv;

and made also a link to /etc/nginx/sites-enabled by command

sudo ln -s /etc/nginx/sites-available/myproject /etc/nginx/sites-enabled

After that: sudo systemctl restart nginx and sudo ufw allow 'Nginx Full'.

Now when I enter http://my_ip_address:83/ I see default nginx greeting and nothing else! Altough I think it should be my Hello There! made by my python-script. Don't know why...

Here is my logs:

2018/02/08 22:17:51 [error] 2394#2394: *1 connect() to unix:/var/www/flaskapp/venv failed (111: Connection refused) while connecting to upstream, client:, server:, request: "GET / HTTP/1.1", upstream: "uwsgi://unix:/var/www/flaskapp/venv:", host: "my_external_ip:83"

And log of uwsgi:

current working directory: /var/www/flaskapp
detected binary path: /var/www/flaskapp/venv/bin/uwsgi
!!! no internal routing support, rebuild with pcre support !!!
your processes number limit is 7157
your memory page size is 4096 bytes
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to UNIX address myproject.sock fd 3
Python version: 3.5.2 (default, Nov 23 2017, 16:37:01)  [GCC 5.4.0 20160609]
*** Python threads support is disabled. You can enable it with --enable-threads ***
Python main interpreter initialized at 0xf07550
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 436560 bytes (426 KB) for 5 cores
*** Operational MODE: preforking ***
WSGI app 0 (mountpoint='') ready in 2 seconds on interpreter 0xf07550 pid: 2320 (default app)
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 2320)
spawned uWSGI worker 1 (pid: 2703, cores: 1)
spawned uWSGI worker 2 (pid: 2704, cores: 1)
spawned uWSGI worker 3 (pid: 2705, cores: 1)
spawned uWSGI worker 4 (pid: 2706, cores: 1)
spawned uWSGI worker 5 (pid: 2707, cores: 1)

Somewhere has been said that I need to reinstall uwsgi and also install pcre, but after doing this still no success, I really tried and searched all solutions related to this but with all effort I am getting nothing..

Please help me to detect the problem and then to handle it.


When using a UNIX socket, the path specified in uwsgi_pass must be the path to the actual UWSGI socket.

That is:

socket = /path/to/uwsgi.sock

Must match in nginx:

uwsgi_pass unix:/path/to/uwsgi.sock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.