0

I Have to make authorize communication between ASA 5525X and an L3 switch 3750, in the switch I've created 3 VLANs, Vlan server, Vlan Workstation, and Vlan Interconnection (Vlan number 5) the Interconnection Vlan is actually the one that is used to link ASA and the L3 Switch.

ASA config :

interface GigabitEthernet0/1.5
 vlan 5
 nameif v-interConnection
 security-level 100
 ip address 10.0.0.2 255.255.255.248
 no sh

L3 Switch config :

interface Vlan5
 description V-InterConnection
 ip address 10.0.0.1 255.255.255.248

interface FastEthernet2/0/24
 description LINK TO ASA
 switchport access vlan 5
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast
!
Ip route 0.0.0.0 0.0.0.0 10.0.0.2

I'm trying to ping from the L3 swith on the ASA interface using the subinterface IP address without success

Is there any hint please for this matter ? is there any other suggestion to connect the switch with the ASA other than what I'm suggesting?

I'll be very grateful if you assist me on that.

Thanks and regards, Azeddine.

1 Answer 1

0

You have set up the switch fa2/0/24 interface in access mode:

switchport access vlan 5 
switchport mode access

The interface must be in trunk mode if you want to tag the frames with the vlan id:

no switchport access vlan 5 
switchport mode trunk

The resulting minimal switch configuration should be:

interface Vlan5
 description V-InterConnection

ip address 10.0.0.1 255.255.255.248
 interface FastEthernet2/0/24
 description LINK TO ASA
 switchport mode trunk

Also, check for switchport trunk allowed vlan command to limit the vlan allowed on the trunk.

However, do you really need vlan tagging on the interface?

You can leave the switch configuration as it is, and change the asa configuration to:

interface GigabitEthernet0/1
 nameif v-interConnection
 security-level 100
 ip address 10.0.0.2 255.255.255.248
 no sh
2
  • Thanks a lot for your answer please do we have to change the config as well in the ASA? Feb 20, 2018 at 15:32
  • I've expanded the answer with more details Feb 20, 2018 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .