0

I'm attempting to install the Trader extension on my mac, currently using MAMP. I believe the install was done correctly but can't seem to use them. Here is my feedback from terminal

sudo pecl install trader

pecl/trader is already installed and is the same as the released version 0.4.0

install failed

Based on that it shows that I have installed it. But here is what I get when trying to use one

Uncaught Error: Call to undefined function trader_cci()

Running phpinfo(); tells me that my extension_dir is below

extension_dir /Applications/MAMP/bin/php/php5.6.2/lib/php/extensions/no-debug-non-zts-20131226/

Now, when I go dig into that directory I can't find trader.so at all so not sure if that could be causing this issue or not

enter image description here

Anybody have tips on a step I may have missed?

Thanks in advance!

-1

I had the same problem. If you can't see trader.so file into extension directory then your installation has not completed properly. You have to install it again.

Before doing so, you have to make some changes into your SIP settings. Follow the below steps to make changes.

  1. Reboot your mac and hold Command+R keys simultaneously. It will boot your OS into recovery mode.
  2. when you see OS utilities screen, pull down utilities menu and select terminal.
  3. type below command csrutil disable and hit enter. It will disable your mac's SIP.
  4. then reboot your mac using reboot command.

Try to install trader once again. After successful installation, change your SIP settings and enable SIP. This is to secure your machine so don't forget enable it.

Hope this will help you... :)

  • SIP does not protect the /Applications/MAMP directory. There's no reason to disable it here, and doing so may cause other problems down the road. – duskwuff Jun 16 '18 at 16:25

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.