0

When I tried to run the logging aggregation I found out the following error generated by elasticsearch:

[2018-02-04T13:44:04,259][INFO ][o.e.b.BootstrapChecks ] [elasticsearch-logging-0] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: max file descriptors [1024] for elasticsearch process is too low, increase to at least [65536]
[2018-02-04T13:44:04,268][INFO ][o.e.n.Node ] [elasticsearch-logging-0] stopping ...
[2018-02-04T13:44:04,486][INFO ][o.e.n.Node ] [elasticsearch-logging-0] stopped
[2018-02-04T13:44:04,486][INFO ][o.e.n.Node ] [elasticsearch-logging-0] closing ...
[2018-02-04T13:44:04,561][INFO ][o.e.n.Node ] [elasticsearch-logging-0] closed
[2018-02-04T13:44:04,564][INFO ][o.e.x.m.j.p.NativeController] Native controller process has stopped - no new native processes can be started

BTW I am running a kubernetes cluster v1.8.0 on minions and 1.9.0 on masters using cri-containerd on Ubuntu machines 16.04.

Any help will be appreciated.

0

This is covered in the docs; https://www.elastic.co/guide/en/elasticsearch/reference/current/file-descriptors.html You will need to change ulimit on file handles available to the process.

To set the limit on file handles persistently, you can add this to the limits file;

# /etc/security/limits.conf

elasticsearch  -  nofile  65536

and restart the service. on Ubuntu it might be necessary to enable pam limits.conf

If you are using systemd, then these values are set in the elasticsearch.service files, but this is normally done by the installed packag. You can override those settings...

/etc/systemd/system/elasticsearch.service.d/override.conf

[Service]
LimitMEMLOCK=infinity

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.