0

We are using Linux mint with ext4 file system mounted with acl option, I want to set a folder such that anything created within it directories or files inherit default permissions and group = 775, I have applied setfacl with options (-R -d -m ugo:rwx)i also tried changing user umask 0002 but still files being created as 644 can someone please help me with this thanks.

0

While not an exact duplicate your question seems very similar to this one : https://askubuntu.com/questions/642236/how-to-make-the-newly-created-files-inherit-the-directorys-permissions

Hopefully the answer there is applicable to your problem also, let me know

  • Sean i have already applied your suggestions but still no no manager@Sesame-mint ~/Desktop/Sesame2 $ umask 0002 manager@Sesame-mint ~/Desktop/Sesame2 $ getfacl DB-3-10 # file: DB-3-10 # owner: manager # group: manager # flags: -s- user::rwx user:manager:rwx group::rwx group:manager:rwx mask::rwx other::rwx default:user::rwx default:user:manager:rwx default:group::rwx default:group:manager:rwx default:mask::rwx default:other::rwx after all above the files are still being created 644 -rw-r--r--+ 1 manager manager 1669067837 Feb 10 19:27 DB-3-101518308853.dat – user313162 Feb 12 '18 at 15:52
0

This is the normal behavior of Linux Mint and some users consider it as a bug.

As a workaround, you can create a new script:

echo "umask 002" > /etc/profile.d/umask.sh

This will set the umask when you login.

Edit #1:

Can you please check this U&L answer? I'd try and run that code:

bash -x -l -i -c 'exit' 2>&1 | grep ' umask '

to verify that umask is configured correctly.

  • Thanks Itai, interesting but the umask is already set to 0002 when i run umask cmd it tells 0002, so you think its not being applied... – user313162 Feb 12 '18 at 15:58
  • Sure will run that in the after hours as i don't want any interruption to server thanks. – user313162 Feb 12 '18 at 17:57
  • The command will not interrupt the server in any way, it’s safe. – Itai Ganot Feb 12 '18 at 18:08
  • I ran above command but I just recalled that I have already created a bashrc for umask and it didn't change anything for me so I removed it again, I have also added umask to /etc/profile.d that didn't help either – user313162 Feb 13 '18 at 3:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.