0

I've setup a CUPS print server on Debian Stretch and I need a way to modify print jobs that don't use A4 page size.

I have clients (iOS) that cannot set the paper size and will send for example a PDF that is in letter size to the print server which will send it to the printer and the job will fail because the paper size is not correct.

The printer is configured with A4 paper.

I'm using the Generic PostScript driver on the cups server and I've set the default page size to A4.

I've also tried to modify /etc/papersize to A4 but that makes no difference.

I've tried lpoptions -p myprinter -o fit-to-page but it has no effect. Also tried lpadmin -p myprinter -o fit-to-page but it has no effect.

I've enabled debugging and can see the following filters are used:

pdftopdf (application/pdf to application/vnd.cups-pdf, cost 66)
pdftops (application/vnd.cups-pdf to application/vnd.cups-postscript, cost 100)
- (application/vnd.cups-postscript to printer/myprinter, cost 0)

If the print job is sent in A4 then everything is fine.

How I can get the cups print server to check if the page size is not A4 and if so fit the content, e.g. letter PDF to A4?

Do I have to write a custom cups filter or is there some other way?

  • Can we just get an answer to the question concerning why cups ignores options at all? I've spent hundreds of man hours on problems like this. – Daniel Widrick Feb 14 '18 at 15:14
  • Did you ever solve this? Same issue – Ominus Apr 24 '18 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.