4

I'm setting the FTP on IIS on my Amazon. I already make it work and can connect if I'm directly on the Amazon server. When I connect from outside, I can connect and accept login, but I cannot list the folder files.

I'm following the instructions here:
https://docs.microsoft.com/en-us/iis/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7

In this image show you need to enter the port so passive mode works.

enter image description here

But in my PC this field is not editable.

enter image description here

0
8

As you can see on the first screenshot:

enter image description here

And as is mentioned also in the page you link to:

Go to IIS 7 Manager. In the Connections pane, click the server-level node in the tree.

I.e. the option can be set on server-level node only (for all sites on the server).

Not per FTP site:

enter image description here

-1

You need to open your Amazon ftp ports and ranges like this:

amazon ports setup

3
  • And the 1024-65535 range is important to make ftp work properly in passive mode – rribas Jul 31 '19 at 2:37
  • How does this answer the question? – Martin Prikryl Aug 9 '19 at 11:55
  • @MartinPrikryl, I meant to warn that no matter what you put on IIS, Amazon blocks all traffic through it's firewall by defaut so that you need to properly open firewall ports like you can see on the image in this link (i.stack.imgur.com/BWFCy.png). Sorry if I wasn't clear about that. – rribas Jul 20 '20 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.