0

I have an old HP Proliant ML350 server with Windows Server 2012 R2 Standard installed.

The server is physically located in a server room but uses a KVM device to connect it to the Monitor, keyboard and mouse down stairs.

The user on the console session using the KVM link is complaining its much slower now then when we had it running Windows Server 2003. We have 5 other users connecting remotely via RDP and they are all fast and have no problems.

Any idea why the console user would find it slow but all the remote users have no problem with it?

Edit: On the console user it takes several seconds longer to open any application than if you are connecting via RDP.

We have a tool that lets us put test points on our software to see the live values. On the local user you have to zoom in and out to refresh the values but as a RDP user you can just sit back and relax while the values on the test points automatically update.

  • 1
    Slow is a relative term. You’ll have to quantify what is “slow” before any help can be given. Users always say the computer is slow when they are waiting for something. – Appleoddity Feb 22 '18 at 5:47
  • The user on the console session using the KVM link is complaining its much slower now then when we had it running Windows Server 2003 - Why are they sitting at the console instead of remoting to it via RDP like everyone else? – joeqwerty Feb 22 '18 at 12:26
  • @joeqwerty I have no idea thats how it was setup for the last 5 years. Ive only been working here for 1.5 years. – Daniel Feb 22 '18 at 22:00
1

Your KVM is almost certainly choking on scraping too many active display tiles. Windows 2003 doesn't have any of compositing features within the graphical environment that 2008 and up do, and remote users should have that stuff turned off by default.

My first suggestion here would be to use your iLO or other IPMI+BMC based solution for getting into this system out-of-band. Much less cable and headache than networking a KVM to do the same job, and BMCs typically have much better firmware than KVMs.

And if you don't want to do that (or even in addition to that), disable all of those graphical "effects" going on in session 0. You might as well be trying to watch Netflix through your KVM with that turned on. Thankfully, this part of the problem has already been answered:

How do I disable the Animations in Microsoft Server 2012?

Just turn every effect off. You don't need any of it; nobody does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.