0

I have a website hosted on commercial G-Suite Google Sites where www version of website works properly, however, the non-www version does not work properly:

# wget www.fashioncodebeautysalon.com
--2018-02-22 21:43:15--  http://www.fashioncodebeautysalon.com/
Resolving www.fashioncodebeautysalon.com (www.fashioncodebeautysalon.com)... 172.217.6.51
Connecting to www.fashioncodebeautysalon.com (www.fashioncodebeautysalon.com)|172.217.6.51|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html’

index.html                                              [ <=>                                                                                                              ]  19.78K  --.-KB/s    in 0.03s   

2018-02-22 21:43:16 (671 KB/s) - ‘index.html’ saved [20257]

# wget fashioncodebeautysalon.com
--2018-02-22 21:43:20--  http://fashioncodebeautysalon.com/
Resolving fashioncodebeautysalon.com (fashioncodebeautysalon.com)... 216.58.195.83
Connecting to fashioncodebeautysalon.com (fashioncodebeautysalon.com)|216.58.195.83|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2018-02-22 21:43:20 ERROR 404: Not Found.

To get into this state, in the GoDaddy console I simply created DNS A record and copied IP address that I got when accessing www version of website. Is this correct way to create DNS A record, because I don't know if Google guarantees that this particular IP address will remain constant over time? Is there some other specific IP address that I should have put instead?

enter image description here

Since I am getting 404, then I am inclined to think that problem is not with DNS, but rather with Google Sites where their web server expects the "Host:" value in HTTP request header to have the "www" prefix. However, I am unable to add such address mapping in Google Sites console because subdomain field must not be left blank as seen here:

enter image description here

What am I missing here?

  • 1
    Try to use same CNAME to www instead of A record for your domain. If it doesn't work, you can create explicit redirection rule (HTTP redirect 301) to redirect from your domain to www name. Most DNS providers have this option. AFAIK GoDaddy too. I use 1and1.com and it's possible there. – Nopius Feb 23 '18 at 11:06
  • @Nopius Perfect, please post your comment as answer. In the GoDaddy console I added HTTP 301 forwarding from default domain (ie fashioncodebeautysalon.com) to www.fashioncodebeautysalon.com and now visitors are always seeing the www version. I guess this introduces one extra step for browser to get to the right website, but I guess that is ok? – Hans Solo Feb 23 '18 at 20:49
2

Adding redirect rule from domain.com to www.domain.com in GoDaddy control panel should work. What about your visitors, getting 301 redirect first time they visit your site, it will be cached in their browser. 301 is a permanent redirect code, as opposite to 302 which will not be cached and redirected each time. Which one to use it's up to you.

  • BTW Google has another nice feature similar to Google Site but for email. You can host your mail domain in Google just with pointing MX records to their SMTP servers and have access similar to gmail. It is called G Suite. First it was free, now it costs starting from $5/month. – Nopius Feb 23 '18 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.