1

I have two older Win 2003 R2 servers acting as DNS, named DNS1 and DNS2. I have two Windows 10 Pro, hard-wired, same network, latest patches. One is a laptop and one is a desktop.

The desktop can ping and access shares on DNS1 and DNS2. DNS1 and DNS2 can also ping the desktop PC. All works fine here.

The laptop cannot ping DNS1 and DNS2, nor can DNS1 and DNS2 ping the laptop. It says the request could not find the host. This happens whether the laptop is connected via ethernet or wifi.

The laptop can ping/access everything else (every other PC is newer than 2003 R2). The issue is only between the Win 10 laptop and the two 2003 DNS servers.

When I run ipconfig /all on the laptop, I noticed that NetBIOS over Tcpip is always disabled (even if I force enable it) on the laptop, but enabled on the desktop. Also, while I am still running a WINS server, the laptop is not showing this, while the desktop is.

I've read that SMBv1 is deprecated in recent versions of Windows 10, but what I don't understand is why the desktop PC is working fine but the laptop is not - even though both are fully updated. Thanks!

2
  • It could be SMB related but you are talking about ping problems, so likely not. However, I recently discovered that Windows 10 has a “feature” that automatically removes the “SMBv1” feature, if It isn’t “needed.” You need to go to programs/features and add SMBv1 and remove the feature that automatically removes the feature. :) but again I don’t think it’s related to ping problems. Feb 25 '18 at 2:46
  • Have you looked at a packet capture to see what the machine is actually trying to do?
    – kasperd
    Feb 25 '18 at 10:22
1

When you say "cannot ping DNS1" do you mean you will get "request timeout" or "Ping request could not find host dns1. Please check the name and try again." ?

In case it is the "request timeout" message, you will have to check any firewall on your laptop or server - but i guess it would be on the laptop, since the other computer is working fine.

If the case is "cannot find the host name", you will have to change your laptop DNS settings to use DNS1 and DNS2 as DNS servers.

I dont know how your DHCP server is configured, but it should provide correct DNS settings automatically.

It might also be a case where you have two or more DHCP servers on your LAN and the computer and laptop receives IP from different DHCP servers, one with the correct settings and the other with wrong settings.

This could typically happen if you server is configured as a DHCP server, which gives out the right settings and you have router with a DHCP server activated which gives out wrong settings.

7
  • The error is saying it could not find it. DHCP is configuring the two DNS servers for leases. There is only one DHCP server. The configuration has not changed for years and has worked fine. The issue is just on the laptop. Feb 24 '18 at 21:48
  • Even with a static IP configuration on the laptop (and defining a WINS server), it will not show the WINS server and netbios over tcpip will still show as disabled. Feb 24 '18 at 21:51
  • You will have to forget about Wins. Check your DNS settings. If you are using static IP, make sure you use correct DNS settings, compare settings from the computer with your laptop. You can also post the settings (ipconfig -all)
    – Mr Zach
    Feb 24 '18 at 21:58
  • The issue happens regardless of whether the IP is static or dynamic. i.imgur.com/w9srmqj.png Feb 24 '18 at 22:10
  • Can you also provide the information from the other computer and you should also include the part showing "Windows IP configuration", the two most important from there is "Primary DNS suffix" and "Dns suffix search list"
    – Mr Zach
    Feb 24 '18 at 22:15
0

I never found an answer to this. NetBIOS refused to turn on even after modifying the a series of suggestions online. I ended up doing a Refresh of the OS and it started working normally. I was getting several other errors indicating that some files were corrupt. NetBIOS and WINS were enabled again and I was able to ping the older 2003 servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.