0

When I run the command yum install mod_php71u I get the following message:

Error: httpd24u-tools conflicts with httpd-tools-2.2.15-60.el6.centos.6.x86_64
Error: httpd24u conflicts with httpd-2.2.15-60.el6.centos.6.x86_64

Do I need to run a command to ignore base CentOS httpd?

What am I doing wrong?

Additional info:

mod_php71u and httpd24u are from the IUS Repository.

yum list installed httpd

Installed Packages
httpd24u.x86_64                                                            2.4.29-1.ius.centos6                                                  @ius
httpd24u-filesystem.noarch                                                 2.4.29-1.ius.centos6                                                  @ius
httpd24u-tools.x86_64                                                      2.4.29-1.ius.centos6                                                  @ius

yum repolist

repo id                                       repo name                                                                                     status
base                                          CentOS-6 - Base                                                                                   6,706
epel                                          Extra Packages for Enterprise Linux 6 - x86_64                                                12,368+86
extras                                        CentOS-6 - Extras                                                                                  50+2
ius                                           IUS Community Packages for Enterprise Linux 6 - x86_64                                              392
updates                                       CentOS-6 - Updates                                                                                  945
repolist: 20,461
  • Ahh, bad IUS packages again. Contact IUS for help, or use other repos. – Michael Hampton Feb 26 '18 at 16:35
  • It's not a bad package, it's working as designed. Please don't disparage the project just because you don't understand it. – carlwgeorge Feb 26 '18 at 17:15
1

This is explained in the IUS FAQs for php56u, but it applies to mod_php71u as well. IUS packages are designed to be used à la carte, so our mod_php packages compile against stock httpd. This means that you can use php71u without being forced to use httpd24u as well. If you want to use both then you need to switch from mod_php71u to php71u-fpm.

  • Thanks carlwgeorge! Consider mentioning this in mod_php package descriptions... would be super helpful! – payling Feb 26 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.