0

I am running WSUS on a Internet connected Windows 2016 Server using WID. I used that as my upstream server to download my updates and use the WSUSUTIL tool to export the metadata and the content to my air gapped systems for patching. I did a wsusutil export

wsusutil export EXPORT201802.xml.gz Export.log

and it ran fine and exported. I then synched the server to get the latest of everything and downloaded what I needed.

I did some clean up of my server using the Clean up utility and Adamj-Clean-WSUS V3.2 script. Now when I do the same command.

wsusutil export EXPORT201802-2.xml.gz Export-2.log

Now I am getting an error in the log and on the screen.

Export failed to export updates. please look at the log file for error details. Fatal Error: Object reference not set to an instance of an object.

The log shows the same error. I haven't made any changes to the system other than the installation of the cumulative 2018-02 update for server 2016. I can't find anything on google about this error with wsusutil. I am hoping I won't have to do a full WSUS reinstall. Has anyone had this problem?

OUTPUT LOG from Adamj-WSUS-Script:

Output

Last line of the Export Log file:

<Update UpdateId="51147b68-d2b4-409c-a228-aca52d049252" RevisionNumber="200" Title="x86"><Files><File Path="E:\WSUS\WsusContent\CA\89E273ACA612D15D588C4E18AF0FBF2F5172BDCA.cab" /></Files></Update><Update UpdateId="8444c7c7-ddc8-4120-bd14-04f58fd86412" RevisionNumber="200" Title="x64"><Files><File Path="E:\WSUS\WsusContent\21\10D1D227DACA78A0A9DBD84466E637DD5ECFA921.cab" /></Files></Update><Update UpdateId="1fa7fbe7-6f24-40c9-8759-9b989f9916a6" RevisionNumber="200" Title="Update for Japanese Microsoft IME Standard Dictionary - KB2880582 (Version 16.0.1065.1)"><Files /></Update><Update UpdateId="65d778dd-ed48-4a92-a7b1-c9c162ce187a" RevisionNumber="200" Title="ARM"><Files><File Path="E:\WSUS\WsusContent\0B\0E2BAC94A33ED92E48DFD3764A7D17CCF678C00B.cab" /></Files></Update><Update UpdateId="6092d6e0-e056-4d4c-a862-b231a15e3948" RevisionNumber="200" Title="Update for Japanese Microsoft IME Standard Dictionary - KB2880582 (Version 16.0.1065.1)"><Files /></Update><ExportError Message="Object reference not set to an instance of an object." /></ExportLog>
0

Found that PREVIEW updates were synced and not downloaded. After running the script it removed the PREVIEW updates and the export worked correctly.

Also if someone is using the Adam script for WSUS please be sure to check the section where you set $True & $False for Previews, IE7, IE8, IE9 and other builds. This can also lead to this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.