1

I am running spacewalk 2.6 on CentOS Linux release 7.4.1708 (Core)

and on starting spacewalk with spacewalk-service start

I observe:

jabberd.service - Jabber Server
   Loaded: loaded (/usr/lib/systemd/system/jabberd.service; enabled; vendor preset: disabled)
   Active: active (exited) since Wed 2018-02-28 16:24:06 UTC; 7h ago
  Process: 4644 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 4644 (code=exited, status=0/SUCCESS)
   Memory: 0B
   CGroup: /system.slice/jabberd.service

Upon further investigation, and googling

#journalctl -xe
Mar 01 00:21:58 gss-spacewalk-1-prod.aws.a.b.c jabberd/c2s[4642]: SASL callback for non-existing host: spacewalk.a.b.c
Mar 01 00:23:13 gss-spacewalk-1-prod.aws.a.b.c jabberd/c2s[4642]: [25] [::ffff:1x.1xx.1xx.82, port=46909] connect
Mar 01 00:23:13 gss-spacewalk-1-prod.aws.a.b.c. jabberd/c2s[4642]: [25] [::ffff:1x.1xx.1xx.82, port=46909] disconnect jid=unbound, pac
Mar 01 00:23:13 gss-spacewalk-1-prod.aws.a.b.c. jabberd/c2s[4642]: SASL callback for non-existing host: spacewalk.a.b.c.

now spacewalk.a.b.c seems to be an aws load balancer:

$nslookup spacewalk.a.b.c
Server:         1x.xx.xxx.80
Address:        1x.xx.1xx.80#53

spacewalk.a.b.c canonical name = internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com.
Name:   internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com
Address: 1x.1xx.1xx.55
Name:   internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com
Address: 1x.1xx.1xx.82

I have searched forums and blogs, but cannot find a resolution of this jabberd not starting

--------------- answer to @tukan ------------------------------------

There are actually 6 programs that run when jabberd is started. Their executable are located in the following locations:

1. /usr/bin/c2s 
2. /usr/bin/jabberd 
3. /usr/bin/resolver 
4. /usr/bin/router 
5. /usr/bin/s2s 
6. /usr/bin/sm

jabberd configuration:

1. /usr/bin/c2s -c /etc/jabberd/c2s.xml        https://pastebin.com/A1Qp44qp
2. /usr/bin/jabberd itself does not have a config ??
3. /usr/bin/sm -c /etc/jabberd/sm.xml          https://pastebin.com/4gi4MR3g
4. /usr/bin/router -c /etc/jabberd/router.xml  https://pastebin.com/cdRZqk5D
5. /usr/bin/s2s -c /etc/jabberd/s2s.xml        https://pastebin.com/nPsMsde3
6. /usr/bin/sm -c /etc/jabberd/sm.xml          https://pastebin.com/s7vQu3VE

c2s and sm are configured to encrypt information that passes through them. The cert and key used to do this are located in the /etc/jabberd/server.pem file.

ports:
[root@gss-spacewalk-1-prod jabberd]# nmap -sT -p 5200-5400 localhost

Starting Nmap 6.40 ( http://nmap.org ) at 2018-03-09 19:11 UTC
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00022s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 198 closed ports
PORT     STATE SERVICE
5222/tcp open  xmpp-client
5269/tcp open  xmpp-server
5347/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 0.03 seconds
[root@gss-spacewalk-1-prod jabberd]#  netstat -nl | head
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:20048           0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:36536           0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:25151         0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:32000         0.0.0.0:*               LISTEN

---------------------Firewall Config ---------------------------------------

# service iptables status
iptables: Firewall is not running.
# sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
  • Could you show us your jabberd configuration? Could you show us the running ports on the Centos? – tukan Mar 8 '18 at 10:40
  • @tukan i updated the question space to answer your question due to ( space and format limitation in comment section ) – kamal Mar 9 '18 at 19:11
  • Great and your firewall config? – tukan Mar 9 '18 at 20:06
  • @tukan firewall and SElinux Status added ^^ – kamal Mar 10 '18 at 4:52
0

Thank you for the configurations. Your configuration looks fine to me. You have only lowercase in your configuration files.

I think you still may be hitting the uppercase host name:

internal-GSS-Spacewalk-123456789.us-east

as your nslookup gives you capital letters in your name

$nslookup spacewalk.a.b.c Server: 1x.xx.xxx.80 Address:
1x.xx.1xx.80#53

spacewalk.a.b.c canonical name = internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com. Name:
internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com Address: 1x.1xx.1xx.55 Name:
internal-GSS-Spacewalk-123456789.us-east-1.elb.amazonaws.com Address: 1x.1xx.1xx.82

Try it your FQDN all lowercase and it should start working. I'm now writing on mobile, I'll fill in the references later when I'm on notebook.

Edit As promised here are the sources:

If hostname contains upper and lower case the communication between jabberd and osad/osa-dispatcher fails

To quote:

"NEVER use UPPERCASE letters in the Satellite hostname, things just don't work! "

Problem installing Spacewalk on CentOS7 (Brand new install)

As weird as it sounds, you should never use uppercase in your hostname!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.