1

This plugin won't let me install and I tried to write in to get help from nginx.. (not a good experience). The plugin says I do not have the daemon installed for python, but I infact do (I believe). I have tried to write in for support but the people at nginx were very rude and told me to pound salt. Any insight as to how to fix this would be much appreciated! I am on centos 6, rest of info is below :)

My error I need help to fix please:

Error: Package: nginx-nr-agent-2.0.0-12.el6.ngx.noarch (nginx) Requires: python-daemon

See actual output:

[root@pod12 httpdocs]# python -V
Python 2.6.6
[root@pod12 httpdocs]# python2.7 -V
Python 2.7.14
[root@pod12 httpdocs]# which pip
/usr/local/bin/pip
[root@pod12 httpdocs]# cd /usr/local/bin
[root@pod12 bin]# python2.7 pip install python-daemon
Requirement already satisfied: python-daemon in /usr/local/lib/python2.7/site-packages
Requirement already satisfied: docutils in /usr/local/lib/python2.7/site-packages (from python-daemon)
Requirement already satisfied: lockfile>=0.10 in /usr/local/lib/python2.7/site-packages (from python-daemon)
Requirement already satisfied: setuptools in /usr/local/lib/python2.7/site-packages (from python-daemon)
[root@pod12 bin]# yum install nginx-nr-agent
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.linux.ncsu.edu
 * extras: mirror.cs.pitt.edu
 * updates: mirror.vtti.vt.edu
Resolving Dependencies
--> Running transaction check
---> Package nginx-nr-agent.noarch 0:2.0.0-12.el6.ngx will be installed
--> Processing Dependency: python-daemon for package: nginx-nr-agent-2.0.0-12.el6.ngx.noarch
--> Finished Dependency Resolution
Error: Package: nginx-nr-agent-2.0.0-12.el6.ngx.noarch (nginx)
           Requires: python-daemon
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@pod12 bin]# 

Update (Thanks Michael) - Now I have the following:

[root@pod12 ~]# service nginx-nr-agent start
Traceback (most recent call last):
  File "/usr/bin/nginx-nr-agent.py", line 13, in <module>
    from daemon import runner
  File "/usr/lib/python2.6/site-packages/daemon/runner.py", line 25, in <module>
    import pidlockfile
  File "/usr/lib/python2.6/site-packages/daemon/pidlockfile.py", line 33, in <module>
    class PIDLockFile(LinkFileLock, object):
TypeError: Error when calling the metaclass bases
    function() argument 1 must be code, not str
1

python-daemon is in the EPEL repository. Install and enable this repo and try again.

2
  • can you assist with second part of question? It installed package but now doesn't run? – Gordon Snappleweed Mar 1 '18 at 5:00
  • That should be asked as a new question. – Michael Hampton Mar 1 '18 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.