I have configured a Domain Controller on a Windows Server 2016 (in AWS). Before setting up the AD I can able to browse the internet. But after configured the AD I can't able to ping the computers which all are added to that domain(but if I use FQDN its working). Also, I can't able to access the internet. But whenever I tried to ping using IP address I can able to access them. Public websites also.

  • My windows domain name: sql.com
  • I tried to add the in the forwarders - Able to access all the websites.
  • In Append this DNS suffix I added sql.com - Able to ping all the computers using their name.

Network Settings:

  1. VPC range:
  2. In DC DNS IP in IPv4 properties:
  3. Domain name: sql.com
  4. Reverse lookup: created (PTR records are also there)
  5. In AWS my AD and other servers are in public subnet. Necessary ports are opened.

My Questions:

  1. Why I couldn't able to ping the servers using their names (before adding the Append DNS suffix).

  2. Why I couldn't able to access the internet (until I have added the to the DNS forwarders.)

  3. If I removed the google DNS IP from the forwarders and removed Append DNS suffix, after reboot the Network shows Public Network instead of a domain network.

Can anyone help me to understand at least first 2 questions,But Im using Windows Server 2012 from past few years where I didn't face any issues like this.

  • I have identified the issue, Its only in AWS, please never mind. – Bhuvanesh Mar 2 '18 at 14:31
  • If you've solved, the issue, you can post an answer. Or you can delete the question. – Michael Hampton Mar 3 '18 at 20:46

I have blogged it. The issue with DNS server's forwarders and DNS suffix in IP properties. It won't automatically add these things in windows server 2016.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.