1

I came across this issue because I'm writing a web application which uses SSRS reports and, after configuring our production SSRS server to use HTTPS we found that reports won't run (we get error 401: Forbidden).

I've since found that if I try to navigate to the URL for the Web Portal using HTTPS I get prompted for login credentials, which doesn't happen if I navigate to the HTTP URL instead. I shouldn't be getting prompted for credentials as both my client machine and the server are joined to the same Windows Domain and I'm an Administrator on the server.

Here's the situation:

  • We have a Dev server on the same domain also running SSRS (identical version and, as far as I can tell, identical configuration). I reconfigured this server to support HTTPS first and I've had no problems with it. I can navigate to the Web Portal URL on the Dev server and it opens without prompting me for credentials.
  • We're using the same SSL certificate for both SSRS servers.
  • The SSRS certificate specifies the domain, so in order to browse to the URL using HTTPS it's necessary to include the FQDN (i.e. to include the domain in the URL).
  • The Dev server is also running IIS because it's also the web server for the Dev environment. The production server only runs SQL Server 2016. I have a suspicion that some configuration that takes place when IIS is installed is the reason why I'm not having the same issues on the Dev server but I don't know for sure.

The reportserver.config file is identical on both servers. The authentication section is as follows:

<Authentication>
    <AuthenticationTypes>
        <RSWindowsNTLM/>
    </AuthenticationTypes>
    <RSWindowsExtendedProtectionLevel>Off</RSWindowsExtendedProtectionLevel>
    <RSWindowsExtendedProtectionScenario>Proxy</RSWindowsExtendedProtectionScenario>
    <EnableAuthPersistence>true</EnableAuthPersistence>
</Authentication>

As I say, this works perfectly on the Dev server and also on the production server if I don't use HTTPS.

Can anybody tell me what configuration I might need to alter to allow connection to the SSRS Web Portal on the production server (and hopefully thereby also fix the reports which won't run) to work using HTTPS and the FQDN without being prompted for login credentials?

  • 2
    Add the URL to your Local Intranet zone in Internet Explorer settings on the client laptop – GregGalloway Mar 3 '18 at 2:51
  • I should have thought of that, that's done the trick. Do you want to add it as an answer so that I can accept it? – Philip Stratford Mar 5 '18 at 12:20
2

Add the URL to your Local Intranet zone in Internet Explorer settings on the client laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.