I am using ubuntu 12.04.5 LTS server version. The kernel it has is Linux 3.13.0-32-generic x86_64.
I need to upgrade it to mainline 4.15 version.
I tried many times but i am unable to upgrade.
Upgrading from 3.13 to 4.1 is not a problem,it upgrades without any hassle.
When i try upgrading to anything over 4.1, i found it asks to solve kmod dependencies. I even installed kmod and its all dependencies form this site: Details of package kmod in trusty | Ubuntu. With this i still get error of dependency so i had to install module-init-tools to kmod from this site: Details of package module-init-tools in wheezy | Debian
and i did sudo update-grub
After this has been installed,it upgrades to 4.15 after reboot. Now i realized it has libc6 version 2.19 and i need to downgrade it else i get this error:
root@ubuntu:/usr/src# apt-get install byobu Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: byobu : Depends: python-newt (>= 0.52.2-11) but it is not going to be installed Depends: tmux (>= 1.5) but it is not going to be installed or screen but it is not going to be installed Recommends: screen but it is not going to be installed Recommends: tmux (>= 1.5) but it is not going to be installed libnih1 : PreDepends: libc6 (< 2.16) but 2.19-0ubuntu6.14 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
And again i have to downgrade this using this command:
sudo aptitude reinstall libc6
After this i try reboot, i get back to kernel version 3.13 again.
Is it that ubuntu 12.05 can't be upgraded to mainline 4.15 or am i missing something here.
Thank you in advance. Expecting help here.