2

There is this GPO in Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Update : Turn off auto-restart for updates during active hours.

GPO configuration and description

I set active hours from 7 AM to 6 PM and say Apply and/or OK then when I reopen this GPO the Active Hours are Start: 12 AM and End: 12 AM.

Why do I get this behavior? How may I check what are the real values being applied? On the client computer you loose access to this parameter.

1

There is this GPO in Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Update : Turn off auto-restart for updates during active hours.

This is not a GPO, but, rather a setting present in one of the GPOs. Please be careful that the same setting can be configured on any of the GPOs present/available.

I set active hours from 7 AM to 6 PM and say Apply and/or OK then when I reopen this GPO the Active Hours are Start: 12 AM and End: 12 AM.

Are you sure that you're editing the same GPO in your management console? Please note that you've to make changes from Group Policy Management Console (GPMC).

How are you checking / modifying the GPO?

Also, are you using gpedit.msc to apply local changes in your local system?

Why do I get this behavior? How may I check what are the real values being applied? On the client computer you loose access to this parameter.

On the client system where you're checking for end-result, you should check for Resultant Set of Policies (RSoP.msc).

In the RSoP output, navigate to Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Update : Turn off auto-restart for updates during active hours -> Check the name of the policy which is applied on this particular setting. Is it the same as the one where you made the changes?

That would give a clear idea of which policy is overriding or getting applied.

Based on the results, there is a possibility that the changes in current GPO is getting overridden by some other GPO applied on that client system, based on the preference.

  • What do you mean by "its rather a setting"? I'm using the Group Policy Management console which leads to the Group Policy Mangement Editor. I don't apply local changes in my local system, I use the gpupdate /force command. The client is in another language so I cannot check for the name exactly but it looks like it is the same GPO. BTW, everything seams to be working now... I'm not sure exactly but the settings stay as set. – Philipili Mar 2 '18 at 15:24
  • @Philipili - 1. The setting "Turn off auto-restart for updates during active hours" is just a normal setting present in Windows Update related Policies, which can be edited/modified in any of the group policy objects you have. 2. gpupdate /force tries to apply the group policy on the local system, and it has nothing to do with Windows Update or GPO as such. – Am_I_Helpful Mar 2 '18 at 15:35
  • @Philipili - As I've worded in second para of my answer, it must have been an overlook at your part to view the correct GPO, it'd have been working earlier too. – Am_I_Helpful Mar 2 '18 at 15:36
  • Thank you for your answer but the fact is that I still don't know why the values were set back to 12 AM - 12 AM when I reopened the setting just after closing it. And I understand now that the setting not being a GPO. I missused the term GPO. – Philipili Mar 5 '18 at 7:47
  • @Philipili - It is good to know that the problem is solved. You may also like to accept the answer if it helped you! Please see how to accept an answer here -> meta.stackexchange.com/questions/5234/… – Am_I_Helpful Mar 5 '18 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.