1

I am having some serious troubles passing through my NIC to my Windows guest running on KVM.

The current driver in use is vfio-pci and I have done the passthrough via Virt-Manager so the XML format is correct. But when I try to start it, it shows Internal Error: Unknown PCI Header Type 127.

lspci -nnv shows Unknown Header Type 7F

02:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel driver in use: vfio-pci
        Kernel modules: iwlwifi

Does anybody have any advice/experience passing through an Intel PCI WiFi NIC on KVM that could possibly help? Thanks.

PS: This device has been successfully pass through w/ ESXi and currently I have passthrough working with my GPU, so you can count vt-d/iommu configuration out of the equation. (And hardware failure, I think. The only real way for me to test is to get this working on KVM or go back to ESXi and if it doesn't work on ESXi then its broken). I have been switching hypervisors for testing a lot latley and I'm hoping to get this to work with KVM, i suspect its not broken hardware that is the issue.

  • Well back on ESXi and the GUI magic of ESXi made the hardware work in my windows guest. Guess in staying on VMware for a few more year's. – FreeSoftwareServers Mar 10 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.