0

I am using linux mint 18.3 Sylvia. My system is taking a long time to boot, as I found a lot of services are running at start up. What I am asking is there any way I could start those services after boot process is completed? Because I dont need those sevices (docker, postgres, mariadb, etc.) as the very first second of my desktop loads.

So, in short:

Is it possible to start service after boot process is completed? If yes, how?

Thanks.

Just FYI here is the output of systemd-analyze blame

     20.342s postgresql@9.6-main.service
     18.825s docker.service
     13.585s mariadb.service
     11.824s vmware.service
     11.807s ModemManager.service
     10.142s accounts-daemon.service
      7.194s dev-sda2.device
      6.056s polkitd.service
      5.859s NetworkManager.service
      5.736s apparmor.service
      5.728s apache2.service
      5.089s vmware-USBArbitrator.service
      4.720s plymouth-quit-wait.service
      4.235s virtualbox-guest-utils.service
      4.134s irqbalance.service
      4.047s ondemand.service
      4.046s iio-sensor-proxy.service
      3.275s media-mehedi-Development.mount
      3.253s media-mehedi-Tutorial.mount
      3.192s console-setup.service
      3.173s lightdm.service
      3.082s console-kit-log-system-start.service
      3.077s rsyslog.service
      3.076s lm-sensors.service
      3.075s systemd-user-sessions.service
      3.009s php7.0-fpm.service
      2.550s gpu-manager.service
      2.484s avahi-daemon.service
      2.046s vmware-workstation-server.service
      2.003s fruhod.service
      1.864s grub-common.service
      1.819s ntp.service
      1.754s thermald.service
      1.661s loadcpufreq.service
      1.563s speech-dispatcher.service
      1.388s redis-server.service
      1.282s lvm2-monitor.service
      1.192s keyboard-setup.service
      1.008s systemd-logind.service
       979ms pppd-dns.service
       970ms systemd-udevd.service
       957ms systemd-tmpfiles-setup-dev.service
       920ms systemd-tmpfiles-setup.service
       910ms colord.service
       893ms binfmt-support.service
       783ms systemd-modules-load.service
       782ms kmod-static-nodes.service
       726ms dev-disk-by\x2duuid-7dd479a6\x2dbeb7\x2d4c24\x2dafe1\x2d22053bdace19.swap
       668ms systemd-journald.service
       523ms systemd-random-seed.service
       520ms systemd-remount-fs.service
       489ms sys-kernel-debug.mount
0

I solved this issue by setting the time load of not necessary service after booting with below commands:

systemctl editor docker.service

you need change docker.service which each service name you would.

then add below lines:

# docker.service time configuration override
[Timer]
OnBootSec=1min
OnUnitActiveSec=1d
AcuracySec=1h
RandomizedDelaySec=30min

save and exit.

0

You should disable not needed services using systemctl disable service_name and when you need once from disabled start it manually running systemctl start service_name Remember to run command with sudo or on root account.

  • this is a very bad and not useful answer. most of those services that in the startup, are useful and necessary. – Hossein Vatani Jun 12 '18 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.