2

Since Windows Server 2016 Update version 1709, insecure guest logons have been automatically disabled.

How should insecure guest logons be enabled again?

In the linked article, Microsoft suggests to do this:

If you want to enable insecure guest access, you can configure the following Group Policy settings:

Computer configuration\administrative templates\network\Lanman Workstation "Enable insecure guest logons"

Note By enabling insecure guest logons, this setting reduces the security of Windows clients.

However, I have done this and nothing seems to have changed, remote access to shared folders without a user logging in doesn't work. This used to work seamlessly before the mentioned update.

The server in question is not currently within a domain. It wasn't either before, when insecure guest logons used to work, or after the update, so this setting has been applied to the Computer configuration as described by Microsoft.

It should be noted that such setting had its status described as Not configured, instead of Disabled, when it was changed to Enabled.

The only related question I found was Windows 10 cannot access network shared locations or drives, but it only mentions Microsoft procedure.

Is there any other setting that should be set for this to work again? Is this not the setting that should be changed?

PS. I understand this is considered insecure.

1

I think this will work Local Group policy editor > Computer Configuration > Administrative templates > Network > Lanman Workstation > Enable insecure guest logons enable it

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.