4

I have created some certificated using certbot's --standalone option but I want to renew them so I run (testing if will get renewed):

sudo certbot renew --dry-run

But for some domains I get the error

Attempting to renew cert from /etc/letsencrypt/renewal/example.org.conf produced an unexpected error: Missing command line flag or config entry for this setting:
Select the webroot for example.org:
Choices: ['Enter a new webroot', '/var/www/ellakcy/']

(You can set this with the --webroot-path flag). Skipping.

So I want when I run sudo certbot renew to be able to autorenew my certificates without the need to provide a webroot path.

How I can do that?

1
  • Enter a new webroot, or specify one as it advised you to do. – Michael Hampton Mar 10 '18 at 1:09
6

This is casued because on /etc/letsencrypt/renewal/example.org.conf the certificate for it also apply on other domains as well so you need to specify the correct webroot for other domains as well in /etc/letsencrypt/renewal/example.org.conf at [[webroot_map]] as well.

For my domain ellak.org.cy that apply on other domains I have specified:

[renewalparams]
authenticator = webroot
installer = None
account=^an_account_hash^
[[webroot_map]]
ellak.org = /var/www/ellak.org/
www.ellak.org=/var/www/ellak.org
ellak.org.cy = /var/www/ellakcy/
www.ellak.org.cy = /var/www/ellakcy/
imap.ellak.org.cy = /var/www/mail_letencrypt/
mail.ellak.org = /var/www/mail_letencrypt/
mail.ellak.org.cy = /var/www/mail_letencrypt/
pop.ellak.org.cy = /var/www/mail_letencrypt/
pop3.ellak.org.cy = /var/www/mail_letencrypt/
smtp.ellak.org.cy = /var/www/mail_letencrypt/
guest8.ellak.gr = /var/www/ellakcy/

So the error has been removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.