0

My setup:

VirtualBox
DHCP/Cobbler VM server (CentOS 7)
PXE VM Client

DHCP/Cobbler server (1 device setup as NAT) '/etc/sysconfig/network-scripts/ifcfg-enp0s3'

TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=dhcp
NAME=enp0s3
UUID=1b9314dd-2ad7-4bf5-bada-9fb0ca727526
DEVICE=enp0s3
ONBOOT=yes
IPADDR=192.168.56.101
PREFIX=24

DHCP/Cobbler server '/etc/dhcp/dhcpd.conf'

ddns-update-style interim;

allow booting;
allow bootp;

subnet 192.168.56.0 netmask 255.255.255.0 {
     option routers             192.168.1.5;
     option domain-name-servers 192.168.1.1;
     option subnet-mask         255.255.255.0;
     range dynamic-bootp        192.168.56.101 192.168.56.111;
     default-lease-time         21600;
     max-lease-time             43200;
     next-server                192.168.56.101;
     class "pxeclients" {
          } else {
                  filename "pxelinux.0";
          }
     }

}

DHCP/Cobbler server '/etc/cobbler/settings'

next_server: 192.168.56.101
server: 192.168.56.101

Cobbler check

[root@dhcp ~]# cobbler check
No configuration problems found.  All systems go.

Mounting .iso for PXE

[root@dhcp ~]# mount -o loop CentOS-7-x86_64-Minimal-1708.iso /mnt/
[root@dhcp ~]# cobbler import --path=/mnt/ --name=CentOS-7

PXE Client

PXE-E53: No boot filename received

PXE-M0F: Exiting Intel PXE ROM. 
FATAL: Could not read from the boot medium! System halted.
0

try dhcpd.conf

ddns-update-style interim;

allow booting; allow bootp;

subnet 192.168.56.0 netmask 255.255.255.0 {
     option routers             192.168.1.5;
     option domain-name-servers 192.168.1.1;
     option subnet-mask         255.255.255.0;
     range dynamic-bootp        192.168.56.101 192.168.56.111;
     default-lease-time         21600;
     max-lease-time             43200;
     class "pxeclients" {
        match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
        next-server 192.168.56.101;
        filename "pxelinux.0";
        }

}

this should work if all your clients boot BIOS mode.

  • Unfortunately that didn't work. I updated the /etc/cobbler/dhcp.template and /etc/dhcp/dchpd.conf file with those settings and I still receive the same error. I really appreciate the response though. – Mark Matlock Mar 10 '18 at 19:10
  • Why don't you get a Wireshark traffic capture, save it as pcap file and uploade it somewhere; the capture will tell us what's going on. – Pat Mar 10 '18 at 19:39
  • Here you go. It's saved as capture1.pcap. drive.google.com/file/d/1bCbC8wlFD0c-kNTxjhuLtrACD0Wwt-gg/… – Mark Matlock Mar 10 '18 at 21:49
  • that capture does no show any DHCP traffic.... – Pat Mar 10 '18 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.