3

I am mounting an ntfs filesystem on a Linux box using the fuse filesystem driver ntfs-3g. I am then doing some operations on the filesystem (git clone to be precise) unmounting and attaching the filesystem to a Windows machine.

Here's the fun part. The git clone creates two directories, images/ and Images/, which because it's Linux git is fine. Then when I attach that partition to the Windows VM and build, one of the tools blows up because it only sees the Images/ directory.

Is there a way I can get ntfs-3g to work in case insensitive-yet-preserving mode, the same way Windows does?

I tried using lowntfs-3g but that makes everything lowercase which also doesn't work for me.

I have tried the mount option windows_names and it doesn't work:

[joxley@host /tmp/ntfs] sudo mount -t ntfs-3g -o windows_names 
/dev/loop2p1 mntpoint
[joxley@host /tmp/ntfs] touch mntpoint/foo  
[joxley@host /tmp/ntfs] touch mntpoint/FOO
[joxley@host /tmp/ntfs] ls mntpoint
foo  FOO

I have also looked at ciops but this creates lowercase filenames on the backing filesystem which leaves me in the same place as lowntfs-3g.

  • From TFM – yoonix Mar 15 '18 at 16:30
  • Yes, I did RTFM and have already tried that. It doesn't make things case sensitive. Updating the question – John Oxley Mar 18 '18 at 18:27
  • Windows developers often assume their code will only run in case insensitive NTFS, when this is of course not true, and take inappropriate shortcuts. If possible, you should file a bug report with the tool's developer. – Michael Hampton Mar 18 '18 at 18:47
1
lowntfs-3g -o windows_names -o ignore_case $@ /dev/sda3 /DATA/B

try to mount with terminal

and

/dev/sda3 /DATA/B  lowntfs-3g  ignore_case,windows_names 0 0 

should be for fstab

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.