I'm a self confessed Linux newbie, having lived and worked mostly within the Windows world for most of my life. I'm making the effort to try moving my virtual host from a Windows box to a Linode instance to try and better learn Linux, and one of the uses I occasionally have with my current Windows VPS is to RDP into it and browse the internet.

I'm aware that this is probably not best practice (from either performance or security), and most of the time I will be learning from the shell, but I do occasionally need to boot into a GUI.

Because of this, I'd like the ability within my Ubuntu installation on Linode to start/stop Windows X and Gnome at will after SSHing in (startx? gdm?), so I've tried:

  1. apt-get install ubuntu-desktop
  2. Reboot
  3. startx

But I've got an error that no amount of googling has helped me with so far, which I'm assuming is something to do with the fact the box is headless and X needs some more configuration that is beyond me at the moment:

root@local:~# startx
hostname: Unknown host
xauth:  creating new authority file /root/.Xauthority
xauth:  creating new authority file /root/.Xauthority
xauth: (argv):1:  bad display name "local.kieranbenton.com:0" in "list" command
xauth: (stdin):1:  bad display name "local.kieranbenton.com:0" in "add" command

X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
Current Operating System: Linux local.kieranbenton.com #1 SMP Mon Oct 26 19:35:25 UTC 2009 x86_64
Kernel command line: root=/dev/xvda xencons=tty console=tty1 console=hvc0 nosep nodevfs ramdisk_size=32768 ro
Build Date: 26 October 2009  05:19:56PM
xorg-server 2:1.6.4-2ubuntu4 (buildd@)
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec  2 15:50:23 2009
Primary device is not PCI
(==) Using default built-in configuration (21 lines)
(EE) open /dev/fb0: No such file or directory
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log

Can anyone give me any pointers as to how to go from here and get VNC/RDP setup? (RDP would be preferred?).



there isn't really a rdp server for linux. However NX is an excellent free, and flexible way to run a persistant, fast remote desktop. this is a complete, step by step guide to setting it up. then you can use the free client from nomachine.com to connect to it.


Is this that tough to find?

Regardless, if I were you, I'd learn to do it all from the command line. Useful skills to have later. If it's isolated applications you need, ssh -X is the order of the day.

  • I'm not being funny, but was that meant to be sarcastic? I have no idea how I'd even start looking for that, and it doesn't even help me, there is no /etc/X11/gdm/gdm.conf on my system. – Kieran Benton Dec 3 '09 at 10:02
  • apt-get install ubuntu-desktop – phresus Dec 3 '09 at 12:58
  • Thats exactly what I said, and that isnt the problem I was asking about? Can you please read my actual question?? – Kieran Benton Dec 3 '09 at 13:11
  • I did read your actual question. I don't use Ubuntu, so I can't speak into its gdm.conf location. I'd assume the docs were right. I'm recommending you use VNC instead if you want GDM. Just use FreeNX if you just want a desktop. So, it boils down to this: local.kieranbenton.com is failing on DNS lookups (adding it to the host file is a hacky fix here). Either way, you're trying to start a remote X session on :0, which won't work without export DISPLAY=something. You can SSH in with proper X forwarding xhost + && ssh -X yourvps or use VNC for GDM, as the link I posted says. – phresus Dec 4 '09 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.