0

Context

I have a Ubuntu 16.04 Kernel 4.4 desktop installation and two randomly CPU-intensive tasks (docker, numbercruncher). I want to prioritize the docker process over the numberbruncher task, ideally up to the level of complete starvation.

I'm aware of "Nice level not working on linux" and therefore disabled the autogroup feature:

⋊> ~ cat /proc/sys/kernel/sched_autogroup_enabled
0

and gave the numbercruncher a niceness level of 19.

Problem

  1. I still see a 200% to 200% distribution between these two processes.

  2. Though I set kernel.sched_autogroup_enabled = 0 in my /etc/sysctl.conf the processes still seem to wear an autogroup:

    ⋊> ~ cat /proc/6408/autogroup 
    /autogroup-287 nice 19
    
  3. Even when I adjust the niceness level of all the processes in the process tree up to the init-Task (and even their associated autogroups via echo 19 | sudo tee /proc/[PID]/autogroup this does not change.

What is the problem here? Why is the setting ignored?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.