0

I have a script that has the following line:

rsync -e "ssh -i /home/me/.ssh/id_rsa" -a /home/me/ws/ me@example.com:/pathtobackups/$(date +%FT%R)/

It has worked for a couple of months, but suddenly it stopped working. It just waits for a while, and when I press C-c i get this message:

rsync error: unexplained error (code 130) at rsync.c(644) [sender=3.1.2]

The problem persists even if I'm using --force --ignore-errors too.

I have no problem with logging in with just ssh me@example.com so I know the server is running. Furthermore, the server does not ask for password, so I know that the ssh key is working. The server is running Ubuntu 10.04 LTS, and the rsync version is 3.0.7. I know that upgrading from 10.04 would be preferable, but I don't have the authority to do that.

I cannot remember any particular thing I did before it stopped working. It may be an upgrade of my system. I'm using Debian v9.4 and most of my system is from stable. I have however a few packages from unstable because I wanted a newer version of Firefox. Those packages are: firefox, libfontconfig1, fontconfig-config and libnss3.

At the moment I have rsync 3.1.2-1+deb9u1 installed. I tried upgrading to 3.1.2-2.1 from the unstable branch, but this did not help.

Do you have any idea what might have caused this and how to resolve the issue?

  • you are using ssh_rsa key id to login to the destination server, did you check are you able to login using ssh_rsa key – Vijay Muddu Mar 21 '18 at 9:26
  • @VijayMuddu Yep. When I use ssh me@example.com I login and the server does not ask for password. – Broman Mar 21 '18 at 9:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.