Here is my configuration (on DC):

this is GPO on domain level

And this is error I got when run the scheduled task

Note: user is just regular on the domain.

What I am missing?

When I run:

gpresult  /user  asap\deltacopy /V

I get this:

INFO: The user "asap\deltacopy" does not have RSoP data.

Which leads to another question: If this user is never to logon to a server how this can work anyway?

  • Did you check (using secpol.msc or rsop.msc or gpresult) that the GPO did, in fact, apply? – user1686 Mar 21 '18 at 13:07

Something is wrong with the "Log on as batch job" rights.

Try gpupdate /force to push the newest GP. It also depends on what the tasks are you'd like the user to execute. If you want the user to run a script or exe, make sure that it is a local resource and not somewhere in the network on another machine. Also try making the user local administrator. Most of the time this does solve the problem. If all that does not help, make sure there are no other policies that are restricting "Log on as batch job". To rule out some of mentioned above, try to manually log on the/ a machine and start the task/s manually.

Please let me know if this worked for you.

  • Thanks, but "Log on as batch job". should work. gpupdate /force - done already, can you take a look at my gpresult, please, I have added it to question. – Dejan Dozet Mar 21 '18 at 13:20
  • I had to look that one up myself but try to logon as user, delete HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy\History, make an gpupdate, log off and try again. This deletes the whole GPO history of this user. – x3l51 Mar 21 '18 at 13:30

At the end my solution was to make DeltaCopy user an Administrator and deny it logon locally.

I understand that this is DC I am messing with, so better this way.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.