1

I've gotten hold of a used Dell PowerVault MD1000 with two MD3000i (aka AMP01) controllers, both of which are configured to the same address. However my attempts to configure them - or indeed perform any action, even "Blink" - fail with "Error connecting to the array management port(s). Please check the management port(s) to verify they are accessible". Additionally, while controller 0 reports status "Optimal", controller 1 reports status "ServiceMode", which I presume indicates an error.

Here's what I've accomplished so far:

  • Get Dell Modular Disk Configuration Utility to identify both ports by connecting the Mgmt port of controller 1 and one of the data port of controller 0 to the network
  • Get an interactive telnet session on the embedded VxWorks by following the instructions here, and having done that -
    • Reset the password using clearSYMbolPassword
    • Dump the existing configuration using netCfgShow
    • Invoke sysWipe. However, it exits immiediately printing the message below. I presume the problem is with controller 1 being in service mode. On controller 0 I get:

-> sysWipe Executing sysWipe. Boards will reboot on completion. 03/27/18-14:58:39 (GMT) (tShellRem1): WARN:
symbol::ControllerInServiceModeException Line 613 File samSymbol.cc value = 201459792 = 0xc020850

Is there a way I can configure the IP addresses, other than getting hold of a dedicated Dell DB9 - PS2 cable?

Can I completely disable controller1 and just use controller 0, which appears to be in better shape? Unfortunately simply pulling out controller 1 doesn't help.

I'm attaching a screenshot from the Dell utility that depicts the configuration. Should I have been able to see the disks here?

Screenshot

Thanks for your attention!

4
  • 2
    Disconnect/unplug one controller, change the ip address of the connected/plugged in controller, reconnect/plug in the disconnected controller? – joeqwerty Mar 27 '18 at 13:52
  • Already tried that before, and re-tried again now with one data port connected. the problems are as before both sysWipe and any action I try from the Modular Disk Configuration Utility fail as they did before. – YitzikC Mar 27 '18 at 14:10
  • Swapping the two controller cards revealed that the "ServiceMode" issue is specific to the slot and not to the card. By removing all disks I was able to complete sysWipe. – YitzikC Mar 27 '18 at 15:41
  • 1
    Side note, if you ever need that serial cable and don't have one on hand, I posted the pinout for DIY-ers here: dell.com/community/PowerVault/… – JimNim Mar 27 '18 at 15:44
0

Eventually I was able to access my disk array using the full PowerVault Modular Storage Manager utility. I wasn't able to detect my array from Modular Storage Manager previously, so I must have done something right...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.