3

After creating an instance in Google Cloud Platform(GCP), I was able to click on SSH and open the browser based SSH console to access the instance. (Auto key copying and connect from console itself without a local ssh client) But I noticed this is not working since a few days and browser hangs (tried on Firefox, Chrome etc).

Has anyone experienced similar issue before?

note : connection is okay with putty/local client as well as from Cloud Shell console (gcloud compute --project "blackforest" ssh --zone "us-east1-b" "test-instance")

1

I just experienced the same problem and was able to fix it.

This is going to sound stupid, 
but it stop the instance and start it again 
on the instance page.

and the google cloud ssh window works again.'

No access from console SSH, it's completely google managed and they should have the free answer as it's a problem on their side instead of dumping to offsite Q&A as a policy.

I did have also have an error 13 for a while, simply trying to open the window again and again. If it wasn't that they hosted dot.llc and AWS wasn't, I'd be on the less user-friendly but more stable AWS.

IF this doesn't work I think the solution is to attach the volume to another instance, basically redoing all the network, IP, DNS, etc. either that or reload all the YUM instances and pull from a back-up. This is a severe approach though, have some instances backed up, I hope I never need to use them. Looks confusing.

Simply intolerable, where I come from it's firing someone if a production server is down and the answer is "We'll get back to you in 24-hours." or the hundred bucks.

But the turn it off and on again works on the cloud (shudders)

That it'd go down in the first place is bad. I've never ever had to turn off a linux server and back on again to fix something before.

| improve this answer | |
  • he he.. understood – Gineesh Nov 2 '19 at 8:40
0

Did you modify the VPC Network firewall rule that allows SSH connectivity to the Google compute engine instance ? Make sure that the IP source range is not restrictive. For example set 0.0.0.0/0 as source range to make sure all IPs can access.

You can find more info on the documentation:

| improve this answer | |
  • Thanks @Django, Yes, nothing changed in VPC or subnet level. As mentioned above connection working via putty (local pc console) or from google cloud shell. Seems something related to web ssh method. Need to check on some more PC's :) – Gineesh Mar 30 '18 at 2:01
  • SSH connectivity from the browser SSH button is initiated by a IP address in Google network completely different than your IP address or local network. That's why you should make sure that the firewall allows 0.0.0.0/0 as source range for SSH access. – Django Apr 5 '18 at 7:22
  • Thank, mm, not sure on that. Thanks @Ahmed, But I have tried same from different accounts and different projects (even from different workstations/browsers). not sure what is the exact issue. – Gineesh Apr 6 '18 at 8:48
0

make sure on instance settings , that you didn't check the option block project metadata .

You can check by clicking on instance name and edit

| improve this answer | |
  • Thanks @Ahmed, But I have tried same from different accounts and different projects (even from different workstations/browsers). not sure what is the exact issue. – Gineesh Apr 6 '18 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.