We are running a Windows 2016 Server for our calculations. We have a Intel Xeon E5-1650 machine with 128GB RAM. We use the server for calculations which normaly need a lot of resources for a long duration to keep the load on the desktop computers low. The Users are connected via rds to the server. I observed, that we are not able to use more than 10 - 15% of CPU per user; even when other users are in idle. So the overall cpu load is very low. I've tried to test it with an script which is normaly very cpu intense, but more than 15% cpu use is not possible, even when I am the only one user which is logged in. As I said before, the computer is a calculation server, so we want to disable any CPU-Limit for the users to get the results faster. Is there any parameter which can be changed in WinServer 2016 to maximise the usage of the CPU? We have this problem since we switched from WinServer 2008 to WinServer 2016.


Windows Server 2016 has no built-in software to limit CPU usage per RDS user.

There used to be Windows System Resource Manager however this is deprecated since Windows Server 2012 R2 i believe and not available anymore since Windows Server 2016.

Third-party applications can still achieve this.

However, if you are sure that no such application is installed and enabled there might be that the calculation applications is not optimized for multithreaded calculations.

For example if your machine has 8 cores. A single threaded application uses up to 100% CPU of a single core. This would result in a total CPU usage of 12,5%

A more common used method for stress testing the CPU is using Prime95. Can you run tests with Prime95? Using this tool you should reach the 100% CPU usage.

  • thank you for the answer. I've testet the CPU with Prime 95 and I was able to stress the CPU up to 100% load. So it seems, that the problem is more with the mostly used software which should be able to use multithreating, which worked well before we changed the operating system. – Michael Mar 29 '18 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.