0

On a Windows 10 computer, the SQL 17.5 SSMS installation fails.

From the logs, it appears that the error is in the VSTA 2015 installation. Running that (vsta_setup.exe) directly fails with the following error in the log file (named dd_vsta_setup_(var.MajorVersion)_20180322092420.log):

[3F28:3D20][2018-03-22T09:26:37]i301: Applying execute package: vsta_hostingcore_x86, 
action: Install, path: C:\ProgramData\Package Cache\{11A9EF3E-6616-31B1-82BC-1080366FA34D}
v14.0.23829\packages\vsta_hostingcore_x86\vsta_hostingcore_x86.msi, arguments: 
' MSIFASTINSTALL="7"'

[23B0:2DCC][2018-03-22T09:26:52]i000: MUX:  ExecuteError: Package (vsta_hostingcore_x86) 
failed: Error Message Id: 1935 ErrorMessage: Error 1935.An error occurred during the 
installation of assembly 'Microsoft.VisualStudio.Tools.Applications.Utilities.
ProjectRetargetService.resources,fileVersion="14.0.23829.0",version="14.0.0.00000",
culture="zh-HANS",publicKeyToken="B03F5F7F11D50A3A",processorArchitecture="MSIL"'. Please
refer to Help and Support for more information. HRESULT: 0x80070005. 

The full log can be viewed here.

One curious thing here is that the culture says "zh-HANS". However, this computer is purely English and has no Chinese installed on it.

Any suggestions on how to get this install to work?

0

I could rename the C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.VisualStudio.Tools.Applications.Utilities.ProjectRetargetService.resources folder but not delete it. Interestingly, the system "followed" the renamed folder and attempted to write to it during the install. Again, it failed and Process Monitor showed 'Access Denied' on that folder.

Given that an Administrator ID was not able to delete the empty folder, I suspected an NTFS issue. Running chkdsk did not indicate a problem, but I ran chkdsk /f /r and rebooted.

The chkdsk log recorded in the Event Log showed no bad sectors, but did show:

Stage 3: Examining security descriptors ...
Cleaning up 9861 unused index entries from index $SII of file 0x9.
Cleaning up 9861 unused index entries from index $SDH of file 0x9.
Cleaning up 9861 unused security descriptors.
...
Correcting errors in the Volume Bitmap.

Running the vsta_setup setup again worked. In the folder mentioned above, there are now folders for 12 languages, not just zh-HANS. I suspect that zh-HANS was simply the first that was to be written to the corrupted folder.

  • 1
    @chun-liu If you can add an answer, I can give you the bounty points, since your comment helped me focus in the actual problem area! – Glen Little Apr 13 '18 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.