I have a Windows Server 2012 R2 that is a Domain Controller and was originally setup with Office 365 integration. Lately it would not sync and would not let me re-link to the Office 365 Account.

I have disabled the integration for O365 and Azure Active Directory. When I attempt to setup the O365 again it says to check to make sure the computer is connected to the internet. I have tried through power shell with the following error.

Enable-O365Integration : Connect to BECWS failed.

  • I have a Windows Server 2012 R2 that was originally setup with Office 365 integration - What exactly does that mean? Do you mean that you're running Azure AD Connect on the server? – joeqwerty Mar 29 '18 at 19:30
  • @joeqwerty - The server is a domain controller and the Azure AD was automaticly setup 3 years ago when the O365 integration was setup. They are linked. – Radar5000 Mar 29 '18 at 19:35
  • OK. I just wanted to clarify what you meant. – joeqwerty Mar 29 '18 at 19:39
  • Can you try without IPv6? Try disabling it from the Nic and try again. You will be able to find the details in the event log as well. – Epoxy Mar 29 '18 at 19:41
  • @epoxy Sorry I forgot to include it but I did disable IPv6 from the NIC and disabled the secondary NIC. Ill look in the event log. – Radar5000 Mar 29 '18 at 20:05

This seems to have been caused by Microsoft changing something on their Office 365 relay servers. If you're seeing an endpoint error in the "SharedServiceHost-EmailProviderServiceConfig.log" file, you can delete the invalid server address from the registry:


I was able to trace the error message to this Microsoft forum post where MVP Susan Bradley provided the resolution. In this case, the resolution was to navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Productivity\O365Integration\Settings registry key and delete or rename the “BecEndPointAddress” registry entry.

Deleting that registry key and restarting all Essentials services should allow you to change the integration settings again the next time you open the Dashboard.

  • this has resolved the problem. Did not see an endpoint error but it worked. Thank you. – Radar5000 Apr 4 '18 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.